Chain dragging sound/noise - 93 4runner V6-RWD-AT

Joined
Oct 11, 2020
Messages
21
Location
Tallahassee
Hello Everyone,
I've been trying to figure out a very odd and intermittent sound which appears to be coming from my front end perhaps the brake/wheel area.
Over the last few months, I've replaced the wheel bearings with Timkens, remanufactured brake calipers from Toyota, brake pads (inexpensive brand from RockAuto). I upgraded my wheels to 17th inch OEM from a 4th gen Tacoma. The rotors and backing plates look good.
I do know I need to replace my inner and outer tie rods. I have a small leak on my power steering pump but I don't think its coming from there.

The sound shows up at random times, it honestly sounds like I'm dragging a chain and its rattling under the car. When I speed up it gets louder. It goes away after awhile but I dont know why. I usually just slow down and press the brakes a bunch of times.

Here is a recording of the "dragging chain sound" - HERE

I recorded it after going over train tracks at less than 25 mph. After I recorded the sound stopped. I went over speed bumps afterwards but didnt return.

I cant replicated it when I'm at my house and when I lift the front end I don't see anything that is loose.

Any ideas or suggestions on where to look?

Thanks again.
 

clx16

SILVER Star
Joined
Oct 26, 2017
Messages
1,961
Location
Alpharetta GA
I am having trouble following your post. Can you clarify the timeline of events? Was the work you did in response to the sound or the sound started sometime in the middle of all the work you did or after?

The noise i hear in the recording sounds like brake hardware not correctly center in the caliper and sometimes rubbing the rotor. Maybe the recording is bad and if it is then it could also be an exhaust rattle.
 

Users who are viewing this thread

Top Bottom