2002 Traction Control issue

Joined
Jan 28, 2006
Messages
1,460
Location
Scottsdale Arizona
Hello I have a friend having traction control issues in his 2002 100 series he will be going down the freeway at 65/70 and the thing will start braking one front wheel then the other out of the blue scaring the crap out of everybody, what are common things to check or is it a take it to the dealership issue?
Kyle
 
Joined
May 15, 2008
Messages
4,006
Location
Phoenix
Sounds like a worn front end components, probably the rack, causing the skid control to go weird. Had the same problem. I replaced the rack and tie rods ends......all good now.
 
Joined
Jan 28, 2006
Messages
1,460
Location
Scottsdale Arizona
Sounds like a worn front end components, probably the rack, causing the skid control to go weird. Had the same problem. I replaced the rack and tie rods ends......all good now.
Where did you take it to get fixed?
 
Joined
May 31, 2003
Messages
9,519
I picked 2 random threads related to this from my search:

 
Joined
Dec 2, 2015
Messages
682
Location
arizona
It is probably the VSC kicking in. New steering rack bushings fixed mine.

However after replacing the rack bushings I went ahead and disconnected the VSC. Even when it works right it's a pain on higher speed dirt roads.

Thanks,
Jim
 
Joined
Jan 28, 2006
Messages
1,460
Location
Scottsdale Arizona
It is probably the VSC kicking in. New steering rack bushings fixed mine.

However after replacing the rack bushings I went ahead and disconnected the VSC. Even when it works right it's a pain on higher speed dirt roads.

Thanks,
Jim
Ok thanks how did you disconnect?
 

Users who are viewing this thread

Top Bottom