Search results

  1. S

    Wanted Bay Area, CA - 80 Series Exhaust Components for 93-94

    Yup sourced the downpipes from someone in Sac, ordered an exhaust kit off of rockauto, and bought cats fr mcgeorge Toyota.
  2. S

    Wanted Bay Area, CA - 80 Series Exhaust Components for 93-94

    I'm looking for both downpipes and catalytic converters for my '93 80 series. New cat's are prohibitively expensive so I'm looking for used cat's and I am fine with used downpipes.
  3. S

    SOLD SOLD

    Are you willing to separate them and if so would it be $200? I just need a rear. I'm in Oakland so I could drive out on a weekend to pick it up.
  4. S

    SOLD SOLD

    Is the $400 for the E-lockers for each one or for both (front and rear e-locker actuators)?
  5. S

    SOLD Oakland, CA - 80 Series Head, Cams, lifters, and 3rd Row Seats

    Hi there, All this got picked up on Friday and I forgot to mark this as closed. Sorry about that and I wish you luck in your search!
  6. S

    For Sale FZJ80 Parts

    I did not receive a PM from you
  7. S

    For Sale FZJ80 Parts

    Good Afternoon, Three questions: 1. Do you know if the cats are the OEM/originals? (trying to finds CA legal cats for cheap is driving me crazy) 2. Were there any exhaust leaks? (not a deal breaker for me, just trying to gauge how much work I would need to do) 3. Would you be willing to ship...
  8. S

    Rough Idle in Drive (or reverse) with 1993 1FZ

    Good point, I had seen that too. I need to search/figure out the best method for confirming that it is not leaking but I'll definitely check it out.
  9. S

    Rough Idle in Drive (or reverse) with 1993 1FZ

    Ok great, I'll make sure to check that those hardlines and what not are clear and that the IAC is making sound with voltage applied. My EGR ports in the intake manifold were packed so I bet that the hardlines and ports may need more attention as well. I actually did the brake booster line last...
  10. S

    Rough Idle in Drive (or reverse) with 1993 1FZ

    Hmmm. Thanks for pointing out the idle issue. I'll check my accelerator cable adjustment again to make sure that isn't causing it. It's run for about 45 min now since the work was completed. It definitely went through the re-learning process with rough idle all the time for the first couple...
  11. S

    Rough Idle in Drive (or reverse) with 1993 1FZ

    I just got my 1993 land cruiser running again after doing the head gasket repair. In park and neutral, the idle is fine (~700-800 rpm when warm). When I shift into reverse or drive, the idle falls to ~400 and often time stalls out. It's almost like the ECM isn't recognizing or compensating for...
  12. S

    Found some bad wiring and think it might be causing my no-start scenario

    I figured I'd respond to close out this thread... The issue of cranking with no start was my fault. When I was fixing the wiring from my first post in this thread, I mixed up the two small gauge wires. When I fixed it, the 80 started right up. Now I just need to sort out why my new fuel filter...
  13. S

    Found some bad wiring and think it might be causing my no-start scenario

    @Malleus Thank you so much! Considering that these wires seem to run to the relays that I measured to be out of spec I'm now concerned that if I put in new relays they will go bad. Thankfully I bought spares so I can try plugging them in to see if I can get fuel pressure. But doing a better...
  14. S

    Found some bad wiring and think it might be causing my no-start scenario

    I haven't checked for codes but definitely adding that to the "to do" list. Thank you for all your suggestions and help!
  15. S

    Found some bad wiring and think it might be causing my no-start scenario

    I'll try shorting the fuel pump to test operation tonight. I've checked for spark 3x times now based off the FSM procedure. Holding the spark plug against the intake manifold next to the ground point results in no spark from the ignition coil. I have not done the ECM checks though. That will...
  16. S

    Found some bad wiring and think it might be causing my no-start scenario

    I'll double check the distributor wire for issues. Yes, CEL is on in "RUN". The VAF was sitting in a box for a couple months in my garage. It likely got bumped around a bunch. No I did not touch the screws. Just unplugged it and removed it while connected to the top of the air box.
  17. S

    Found some bad wiring and think it might be causing my no-start scenario

    Hi All, My head gasket went out last October on my 1993 80 series. After a bunch of personal drama I finally got it reassembled earlier this month but it won't start. There is no spark and no fuel despite it running when I started disassembly in Nov'21. The truck cranks strong with a brand new...
  18. S

    SOLD Oakland, CA - 80 Series Head, Cams, lifters, and 3rd Row Seats

    All of this is free if you come pick it up! Take what you want/need. Cylinder head came off during my head gasket replacement and is very warped (~0.030"). Take it if you want otherwise I'm sending it to the metal recycler. I have the cam bearing caps and the bolts. Camshafts have some rusting...
Top Bottom