Search results

  1. 2

    Rear axle breather clogged?

    Noticed that the top of the rear axle appears greasy. Upon closer inspection, I noticed there is what appears to be a breather tube - a rubber hose with a clamp on it, which goes for about a foot and has a nipple at the end. The grease seems to have spewed out of the port where the hose sits on...
  2. 2

    Busted transmission hose

    I noticed a slight drip of something under the car. Upon closer inspection, I noticed that the steel tubes that run the tranny fluid for a short distance right before it goes into the tranny intercooler are leaking. I took the rubber hoses that clam onto the two tubes, and there was an obvious...
  3. 2

    Unknown unplugged connector

    The steel tubing that runs transmission fluid to the tranny cooler popped a leak the other day. I took the front grill off to fix that, and noticed a 2 wire connector that was dangling loose behind the top of the tranny cooler, so I plugged it in. Later at night, at about 5 am my car alarm...
  4. 2

    Alternator Saga - Help!

    I've had a grinding noise coming from my alternator area for a while, and although it's been charging fine, I decided it might be time to replace it. I just received a remanufactured alt that I bought on ebay and put it in. Well, the grinding noise went away, but it ain't charging! Now before I...
  5. 2

    Huge engine oil leak! help!

    Just happened to notice it randomly. Checked my oil this morning and it was mid way on the hatching on the dipstick. Drive about 150 miles and a few hours went up to my car and noticed the whole underside soaked. It’s all over everything on the drivers side lower half. Can’t tell where it came...
  6. 2

    Whose E-brake Actually Works?

    Does anybody's e-brake actually noticeable brake the vehicle when you're moving at highway speeds? Even after adjustment, mine holds an incline parked car, but doesn't do s*** when I'm driving at speed. Also, for people who are so paranoid about not using the e-brake when parking on an incline...
  7. 2

    LX470 Whistling Roof

    I did read through all the threads on this, and I taped off with masking tape all seams of the windshield and all seams of the sunroof. I also slid back the roof rack cross member. Still. Howling wind noise at speeds around 40+ mph. I am at a loss for where this whistling can be coming from. The...
  8. 2

    ML sub on 2002 LX question

    Previous owner replaced my sub with a kicker brand or something. Housing is still there but when I bought the car, the connector to the sub was disconnected. I connected it and now when playing music, the sound goes dead for a second and comes back often. I have to think the ohms are mismatched...
  9. 2

    Wanted  Anybody have a Mark Levinson Subwoofer?

    Just realized why the sound keeps kicking out occasionally on my LX with ML system, especially at louder volumes with more bass. Previous owner installed some sort of wrong sub into the box and that's probably my problem. Says kicker on it, instead of whatever the original ML should say. I...
  10. 2

    Brake Cylinder Misconception

    I read a few people here saying that when you go to bleed the brakes, you tend to step on the pedal harder than you normally would, causing the seal in the cylinder to go past its normal stroke length, and marring the seal, creating a leak - or something like that. Well I'm hoping more people...
  11. 2

    Brake fluid level?

    Had to replace a rusted brake line and everything seems to have gone well. Just noticed that to add fluid, it says to pump brake pedal 40 times and then add fluid. After doing this, I turn key on, pump works for about 35 seconds and stops. Level remains between min and max. I remember before...
  12. 2

    Busted brake line

    Lucky it happened right on my property. I was dragging a fallen tree away from my road in 4LO. When I was done I noticed my parking brake light, the red one all the way on the right was illuminated. My parking brake never worked so I was curious why it would go on all of a sudden. Figured maybe...
  13. 2

    Tapped into fuse

    Just noticed this in my LX and wondering why. Could this just be where the PO chose to tap into power for the aux sat radio? If so, why would t need two separate wires tapped in, and why into those specific slots? Manual says one of those fuses is for AHC. The other is something else. Any ideas...
  14. 2

    Tranny starting to slip?

    I’ve noticed lately that after slowing down to a stop, sometimes I will hear and feel a thump as though I got rear ended by a tiny little bump. Seems like a rough down shift or something. Doesn’t happen every time I slow down, but I’ve noticed it probably about 5 times now. Is this the beginning...
  15. 2

    Should this be plugged in?

    just went to clean my throttle body and noticed this little rubber hose was completely disconnected, and looks like for a long while since the plastic piece that it should be sitting on looks dirty. Is this by any chance supposed to be disconnected? What is it for? Thanks
  16. 2

    What year is your 100-series that had brake failure?

    Building on the previous poll thread about brake failures, I think it would be good to narrow down which years suffered more of the brake problems and what they were. Perhaps certain model years had more problems with the electrical contacts corroding while others had a pump prematurely stop...
  17. 2

    Speaker stopped working after refoam

    Wondering if anybody has faced this? Just got a refoam kit from SimplySpeakers and installed new foam on my drivers side front speaker. The speaker used to rattle before, which is why I installed it. But I know it at least worked somewhat. Now after putting everything back together, it doesn't...
  18. 2

    Cassette Tape Adapters

    Guys I'm going nuts! This whole thing is sort of trivial but here's the deal. I bought a random cassette tape adapter that has the 3.5mm cord coming out of it and have been using it in my LC for a year now. The sound quality is excellent, no noise at all. Bought another one and it sounds like...
  19. 2

    VSC TRAC VSC OFF Lights on

    Hey guys, quick question. I was sitting in my 02 LX idling for a good 10-15 minutes when I noticed both the VSC TRAC and VSC OFF lights came on. I put it in drive and moved a few feet and the lights turned off and have stayed off. I was almost able to forget about it, but I also kinda still...
  20. 2

    AHC Globe leak

    Well I did an AHC fluid change this weekend. Before I even started, I went to put the suspension in Low mode, and siphoned out the fluid out of the reservoir. When I laid down to start draining the fluid out of the bleed fittings, I noticed a few drops of fluid hanging from the globes. Seems...
Top Bottom