TPS/APPS problems

Discussion in '100-Series Cruisers' started by NMuzj100, Dec 27, 2006.

  1. NMuzj100

    NMuzj100

    Messages:
    3,479
    Location:
    Gleneagle, CO
    Thottle Position Sensor/Accelerator Pedal Position Sensor problems

    A Readers Digest on the TPS/APPS issues with links to the relevant threads. Send me any feedback/corrections/recommendations in a PM and I'll make changes.

    TPS = Throttle Position Sensor
    APPS = Accelerator Pedal Position Sensor
    TB = Throttle body

    Known issue 1998-1999
    Sudden lack of accelerator response, “Limp Mode” (e.i. approximately 25% power), power available only when "floored"
    May be associated with cold weather
    CEL with codes
    • P0120 – TPS (98 FSM DI-38)
    • P0121 – TPS (98 FSM DI-44)
    • P1120 – APPS (98 FSM DI-104)
    • P1121 – APPS (98 FSM DI-104)
    In TRAC equipped vehicles may set "VSC/TRAC" and "VSC OFF" lights as well.
    If engine is shut off the truck may start with no sign of the problem and drive normally.
    If the truck drives without problem the CEL may go out after a number of miles.
    Pulling the EFI fuse from the fuse block for a few minutes will reset the CEL.

    Repeated occurrences are usually solved by the replacement of the APPS (~$270) and sometimes the TPS. (~$70). Dealers often recommend replacement of the entire TB (~$1050).

    The TB assembly from a 01-02 Tundra is the same part number and maybe easier to locate used.

    R&R covered in the FSM SF-35.

    Possible causes
    • defective part design (APPS part# has been "updated" 4x)
    • dirty throttle body
    • dirty throttle body possibly caused by EGR system
    • bad electrical connections

    During replacement it is recommended that you clean the throttle body.(FAQ - throttle body cleaning)


    Some threads ....

    davidsob - An illustrated guide to replacing your APPS

    Val678 – TPS/APPS problems in a 99 LX

    DMX84 – TPS problems

    EdsCruisin – APS problem possibly caused by build-up in the throttle body

    EdsCruisin – APS problem and even i4c4lo suffers from TPS

    TPS problem poll by rph1974 - Post up! Even you lurkers with no problems. ;p

    HI Trek - CEL code 'P1126' --> Magnetic clutch

    PSDarmoured – TPS failure in a bad spot

    calimaridog troubleshoots an electrical problem related to a starter job – fj55-100 explains dirty throttle body problems in post #11

    Dealer wants to replace entire thottle body at $1400 - onesprung60 explains why and provides a "migrating grease" theory of TPS problems

    Maingear troubleshoots a P1128 Throttle Control Motor Malfunction and Chad in Bangkok may be experiencing a TPS problem

    TPS limp mode, now OK, fix or not? - Landpimp (Part # details from SinCity100)

    loss of power? - AFRIKANZ struggles with "twit" dealers and a non-OBD2 EC market 100

    yotor no motor

    Wellcraft - Sudden loss of power on freeway... and symptoms before a CEL

    jaysdead40 - APPS results in cold start problem

    Ullr - High idle after new APPS

    Newbie suffers APPS - tommy854runner

    shmelvin is left stranded - leads to APPS discussion

    TPS setup with a Scangauge - aimCOtaco

    truggier - 1999 100 drops dead intermittently
    Last edited: Dec 21, 2010
  2. ammodragon

    ammodragon

    Messages:
    8
    Location:
    Clinton, UT
    Thanks for all the info!
  3. e9999

    e9999 You want to do what...? Moderator

    Messages:
    15,192
    Location:
    PRK
    nice, thanks for taking the time.
    have put it in faq
  4. yellowstoner

    yellowstoner

    Messages:
    264
    Location:
    Gilbert, Arizona
    I was recently having the same issues with my '98. Read up on the issue here on MUD (thanks to all who have contributed to this APPS/TPS topic), went and bought the APPS & installed it yesterday. Problem solved!
  5. mmuthart

    mmuthart

    Messages:
    305
    Location:
    Boise, Idaho
    I've been sitting on a piece of very interesting information for over a year now and saw this thread come up and figured it was time I shared...

    Like many, our 2000 LC was going through TPS & APPS issues, according to the codes anyway (I got codes for both at different times).

    My solution for a couple years of occassional reoccurance was to clear the codes and clean the throttle body. I really believed cleaning the throttle body gave me 6 months + of problem free operation.

    Then only a couple of months went by and it through a TPS or APPS code again (don't remember, I seemed to get both at diffferent times). So I started doubting that my TB cleaning was the solution. I started shopping for a used TB from a Tundra.

    Well, before I ever found and bought one, I had removed the APPS and looked for some way to clean it. It is a sealed unit and I could do nothing. When I reinstalled it, I pumped it's electrical plug full of dielectic grease. Got busy and never got around to finding a used unit...

    Well, it's been well over a year and NO CODES. All I did that could have made any difference was the dielectric grease on the APPS plug.

    Worked for me; I say it's worth a try!!
  6. NMuzj100

    NMuzj100

    Messages:
    3,479
    Location:
    Gleneagle, CO
    When I first experienced intermittent problems (every 6 months or so only in bad weather) I was hesitant to change the part too. Especially when it wasn't clear that a new part would not have the same issue.

    But then the thing had a habit of failing intermittently but only when my father-in-law was driving the truck hauling my kids around. I was then forced to fix the problem in a permanent way.

    I did a destructive look into the old unit and found that the sweeping contact points had left streaks of copper across all the contact pads on the dial that might have been shorting out. No other obvious failure point could be seen but opening the sensor had resulted in a lot of very small pieces so it was hard to say what the problem could be.

    Hope you fixed it.
  7. polk

    polk

    Messages:
    1
    Hello. I many read that people has problem with their Throttle Position Sensor. I can't understand how I can alone to adjust it?
  8. OregonLC

    OregonLC Brown Thunder Roles SILVER Star

    Messages:
    3,862
    Location:
    Portland, OR
    What are you trying to adjust and what year is your vehicle?

    There are two components, don't confuse them. APPS = accelerator pedal position sensor. It's at the throttle body (TB) on pre-03 and at the pedal on 03+. TPS = throttle position sensor is connected to the throttle body and validates the position the servo as moved the butterfly.

    03+ have no adjustment from what I understand. Pre-03 you can take slack out of the cable at the TB. If you're not experienced at this, be very careful as you don't want to have any chance that you will take out so much slack that the TB is open at idle.
  9. Trunk Monkey

    Trunk Monkey Moderator

    Messages:
    7,539
    Location:
    Salt Lake City
    Looks like it's my turn. While sitting waiting for the kids at school I noticed the tach jumping just ever so slightly. Scangauge showed actual RPM bouncing between 650 and 750. Later that day when pulling out of the driveway it went into limp mode. Turned the truck off and restarted, everything's fine. CEL came on - P0121. Crap. So I'm guessing I start cheap and just do the TPS for now?
  10. AimCOtaco

    AimCOtaco ...---... SILVER Star

    Messages:
    972
    Location:
    Longmont CO
    Nah, buy a clean new OEM throttle body and be done with it forever... It's only their college fund!

    TPS error could just mean the motor did not put the plate where is should due to gear train issues and the TPS is fine... or it could be the TPS.

    My opinion on it is that the mechanicals (non accesible/serviceable) bind and freak out the 'tronics. Thats why I say pony up big and forget it.
  11. I haven't changed my APPS, and I'm at 404000km. It codes more frequently this winter, so I'll likely change it in the spring. It has been fun to watch the progression, from the early rare codes, to the winter where it would code at exactly -13C to now where it will almost code reliably if it is below freezing and the vehicle hasn't warmed up. I'm pretty sure the voltage that it reflects gets out of spec slightly and causes the code. I may try some dielectric grease this weekend.

  12. Trunk Monkey

    Trunk Monkey Moderator

    Messages:
    7,539
    Location:
    Salt Lake City
    CEL came back so I replaced the TPS. Let me tell you, in one of these threads there's a link to a Lexus forum that has pics of a TPS replacement on an LS400. Well, the LC is NOTHING like it. I was looking at the pics thinking "look how much room I'll have to wrench". Wrong. There are air and coolant hoses and wires in the way that have no wiggle room in them.

    The FSM has some pictures of removing and replacing the TPS and I'm still not sure how they have them oriented. They also talk about putting the TPS into place and then rotating it 15* to screw it in. Well, the picture shows twisting one way, the written description says opposite, and there's not enough room in there to rotate anything anyway.

    I ended up just jamming it in there and screwing it in. When I started the truck, things were no better. I thought it might have been due to the minor adjustments it needed, but nothing made it better. Called a friend that's a Toyota employee, he suggested disconnecting the battery for a bit. Did that and everything's running fine. So, if you replace the TPS (or APPS) disconnect the battery before you start things back up, otherwise you may think that you didn't fix anything.
  13. ttomsauto60

    ttomsauto60

    Messages:
    1
    I have a 1999 land cruise v8 4.7 can anyone tell me how to bring the the plate inside where the app sensor come back in place where the app snor goso ican have full throttle I replace the new app sensor but I don't haves good panel I have to push hard on the gas pedal to go at least 40 miles please help on email me at ttomsauto@aocom I'm going crazy trying to figure it out should I pull ecm fuse or clean Tbi thanks for any help
  14. toyotarust

    toyotarust

    Messages:
    3
    Location:
    CA
    2000 Toyota land cruiser with two codes P1120 and P1121

    Took our 2000 Toyota land cruiser for a smog check which it passed and drove it home that day but the next day after after driving for about 2 blocks the gas pedal stopped responding and the VSC off light plus the check engine went on. We were able to drive it back home by pushing the has pedal all the way down as that was the only way the truck was able to move. The scanner gave only two codes: P1120 and P1121 which point to the Throttle Position Sensor. Does anyone know if the smog check is what triggered the sensor to go on? or is it just a dirty or failing TPS?

    I reset the codes with the scanner and will wait for it to happen again before I go out and buy a new TPS.
  15. OregonLC

    OregonLC Brown Thunder Roles SILVER Star

    Messages:
    3,862
    Location:
    Portland, OR
    It wasn't the smog check. Be glad you had an early TPS or you wouldn't have been able to drive at all, the later models do not have a cable backup.
  16. Does anyone have anymore info on the TPS positioning here? I installed one today and the truck will not even idle now.
  17. kennyao30

    kennyao30

    Messages:
    393
    Location:
    Huntsville, AL
    If it's revving or idle bouncing.... Your tps is installed wrong. Took me a while to get mine right but you have to twist it into place... And you need a scan gauge to set the tps to 13-16%
  18. Jordan345

    Jordan345

    Messages:
    338
    Location:
    Toronto
    I manually twisted mine to about 15%. Works well


    Sent from my iPhone using Tapatalk
  19. Latest values... going to try and adjust.

    ForumRunner_20140216_115734.png



    ForumRunner_20140216_120054.jpg

    Beamed from my Galaxy 4 using IH8MUD to your computer screen
  20. That pic did not come out right... was at 20% and now at 15%. There are some instructions in the fsm to take readings with apps disconnected. .. did not seem to matter either way.
    Still waiting for CEL to clear and cleaned out the throttle body while I was in there. Chemtool makes some good stuff with nice long nozzle to reach up into the opening.

    Beamed from my Galaxy 4 using IH8MUD to your computer screen

Share This Page