Builds Work In Progress aka: Badass (3 Viewers)

NeverGiveUpYota

Dare me.
SILVER Star
Joined
Mar 28, 2011
Messages
6,754
Location
East Hampton, CT
 
Added coolant back in. So far so good just sitting still. Not running yet. My Wonder Woman status is wiped after the stupid calisthenics I had to do yesterday for that plug and then on my feet working till 11:30, and up at 6:30 to grab groceries and zoom off for kid at 8:30. Did some bee winter hive prep. They’re still flying even on this cool 50 degree day. I really love them, such a neat hobby to have taken on. Still on my feet now. Not a big wine drinker but I didn’t buy beer so it’s a lazy pasta dinner and wine night for me.
 
Last edited:

NeverGiveUpYota

Dare me.
SILVER Star
Joined
Mar 28, 2011
Messages
6,754
Location
East Hampton, CT
 
Wheel is cocked from ages ago. I’ll get to it eventually. And I filled up yesterday just to know it was full to hit the trip. I had about 1/2 a tank in that pix. :)
Added front DS this AM.
Did a few more miles today on the hw and on some dirt/old pavement and it rolls well. Didn’t put it in 4W tho it would have been a good moment to try. I had a passenger so was a smidge distracted. But been so long since I drove it I’m hypersensitive to everything again. Coolant gauge actually did two mini spikes on me but dropped so fast know it was the fuel even tho that one didn’t jump at all. Even w/ a full tank it’s where you see it in the other photo. Seems like I feel a vibration at higher speeds but my u-joints are basically new so I don’t think it’s that. Idk, could just be the truck and me being overly vigilant.

New sticker. And freeze plug still holding. 🤞

C2F06788-BECB-4C77-8AA8-5F7E3917EDCB.jpeg


9D9647A2-3C0A-49F2-B66B-0FCFDC755BE9.jpeg


B98F4789-5D08-48E1-8731-C9A5D485E010.jpeg
 
Last edited:
Joined
Mar 4, 2016
Messages
1,019
Location
Boulder, Co
Wheel is cocked from ages ago. I’ll get to it eventually. And I filled up yesterday just to know it was full to hit the trip. I had about 1/2 a tank in that pix. :)
Added front DS this AM.
Did a few more miles today on the hw and on some dirt/old pavement and it rolls well. Didn’t put it in 4W tho it would have been a good moment to try. I had a passenger so was a smidge distracted. But been so long since I drove it I’m hypersensitive to everything again. Coolant gauge actually did two mini spikes on me but dropped so fast know it was the fuel even tho that one didn’t jump at all. Even w/ a full tank it’s where you see it in the other photo. Seems like I feel a vibration at higher speeds but my u-joints are basically new so I don’t think it’s that. Idk, could just be the truck and me being overly vigilant.

New sticker. And freeze plug still holding. 🤞

View attachment 2504103

View attachment 2504104

View attachment 2504105
have you changed your body mounts? I was really surprised how much that helped with vibrations.
 

Users Who Are Viewing This Thread (Users: 2, Guests: 1)

Top Bottom