Vintage Air kit for 55?

Joined
Aug 11, 2020
Messages
399
Location
Albuquerque
Hi Everyone,

After a long hot summer in New Mexico I've been seriously contemplating putting AC in my 73. I've gone through the 55 AC threads but see mostly OEM or clevery pieced together systems which are probably gonna be over my head. I also see the Vintage AC systems the guys use in the 40's seem pretty straight forward but it looks like they take a lot of fab to get them to work in a 55. Going down that path I found that JT Outifitters lists their VIntage AC kit as bolt in ready for the 55. From what I've read elsewhere, I find this hard to believe, unless they've updated the kit since the older posts about them.



So does anyone know if it's actually bolt on ready and if not, how crazy are the mods to get this system into a pig? Next, what about the alternator output? I recently replaced my original with one that I think is 45amps. Is that gonna be enough? Feels like it might be pushing things a bit. Going to a bigger alternator would likely mean upgrades eslewhere I'd assume.

Anyway, thanks in advance and sorry if I missed this all in other threads. I couldn't seem to find my answers anywere.
 
Last edited:
Joined
Aug 11, 2020
Messages
399
Location
Albuquerque
I installed a single wire 155A alternator and didn’t have to do anything except drive it.
Good to know. I thought I read a while back that the stock wiring on the early pigs was pretty small gauge and a big alternator could overload it and the fuse block..maybe not. The wire for the entire electrical feed into the fuse block is pretty damn thin form what I see. Maybe 8 or 10 gauge? Regardless sounds like upping the alternator some isn'ts that big a deal.

What alternator did you use?
 
Joined
Oct 18, 2002
Messages
6,430
Location
Cottonwood, Az.
-

171F69C5-1A7F-47AB-B0F4-909F512B74E5.jpeg
 

Gordobe

SILVER Star
Joined
Apr 21, 2011
Messages
1,153
Location
Ojai, CA
What alternator did you use?
Hunting the web and found this. Brand x I guess, but it came with offset brackets to fit the 2F. Chinese bearing were shot lived. Had a local rebuilder go through it and holding up. One wire is so you don’t run it through the stock wiring. The amp meter will not detect the charging of the battery. win some loose some
418C6E5A-3491-4C30-A99C-8485D753DB90.jpeg
 

PabloCruise

SILVER Star
Joined
Jun 3, 2004
Messages
21,198
Location
Northern Colorado
Hunting the web and found this. Brand x I guess, but it came with offset brackets to fit the 2F. Chinese bearing were shot lived. Had a local rebuilder go through it and holding up. One wire is so you don’t run it through the stock wiring. The amp meter will not detect the charging of the battery. win some loose someView attachment 2790153
But you could wire in a voltage to see system voltage, eh?
I think there is a reason they don't run all the system amperage up behind the dash any longer...
 
Joined
Aug 11, 2020
Messages
399
Location
Albuquerque
Here's what a few of us are running....

I'm guessing you have details about your install with these systems on your build thread. I'll see what I can find there.

As to my original question on that specific system, I guess I'm gonna contact the seller and see what he has to say. I know they don't have the best rep in this forum, but I'll see what they have to say about it for good measure.

And as to adding the AC as Fall rolls in, lol...Coming into some disposable income soon is all. Install ac now or invest it wisely? 😆 I think we know how that will play out
 
Joined
Aug 11, 2020
Messages
399
Location
Albuquerque
I'm guessing you have details about your install with these systems on your build thread. I'll see what I can find there.

As to my original question on that specific system, I guess I'm gonna contact the seller and see what he has to say. I know they don't have the best rep in this forum, but I'll see what they have to say about it for good measure.

And as to adding the AC as Fall rolls in, lol...Coming into some disposable income soon is all. Install ac now or invest it wisely? 😆 I think we know how that will play out
Ok, just got off the phone with them. As I originally guessed, it's not a 55 specific system and will require some mods to make it work. Sounds like most of those mods are in removing the eom heater box and hanging the new unit off the dash, and getting it connected to the defrost ducts. I think I saw a thread here or on another forum where somebody gave some detail on this. I'll link if I find that. So now back to do I think I can manage those mods or not and do I really want this system 🤔
 
Joined
Jun 12, 2009
Messages
1,414
Location
Durango, CO
I installed the Classic Auto Air custom cooler IV system. My thread walks through the install around post #575.


 

Users who are viewing this thread

Top Bottom