FJ40 Carb/Accelerator Linkage

Discussion in '40- & 55-Series Tech' started by jrcfj40, Feb 27, 2018.

  1. jrcfj40

    jrcfj40 SILVER Star

    Messages:
    195
    Media:
    8
    Albums:
    2
    Likes Received:
    22
    Joined:
    May 17, 2010
    Location:
    Virginia
    I'm not sure I have my linkage connected correctly or I have a wrong part or two.

    It seems like the linkage to gas pedal rod is on a pretty good angle as well as the linkage to carb rod. It seems like the ball on the gas pedal would be better aligned if it were on the other side. It's a 5/1977 FJ40.
    IMG_8119.JPG IMG_8117.JPG IMG_8116.JPG
     
  2. imyahucklbrry

    imyahucklbrry "En cervisia veritas" SILVER Star

    Messages:
    902
    Media:
    6
    Albums:
    1
    Likes Received:
    1,361
    Joined:
    Jan 29, 2014
    Location:
    GA - As close to the lake as I can afford...
    Don’t think/know of a difference in ‘77 vs. my ‘82 but the accelerator pedal on mine has the ball connector on the opposite side of yours...
     
  3. imyahucklbrry

    imyahucklbrry "En cervisia veritas" SILVER Star

    Messages:
    902
    Media:
    6
    Albums:
    1
    Likes Received:
    1,361
    Joined:
    Jan 29, 2014
    Location:
    GA - As close to the lake as I can afford...
    Pictures of mechanical linkage pedal...

    2D9BB94F-939A-4A76-A02C-90380C2CAF46.jpeg 4764D354-F416-4229-BBFF-38832F15B3D3.jpeg
     
    thebigredrocker likes this.
  4. 77mustard40

    77mustard40 SILVER Star

    Messages:
    1,254
    Likes Received:
    145
    Joined:
    Nov 28, 2010
    Location:
    Austin, TX
    I’m 8/77 but had aftermarket carb setup when I bought her. Went back to stock carb several years ago and had to cobble all my pieces together. Here’s what my linkage looks like from the pedal to the accelerator shaft, mine has the short vertical shaft straight up from the pedal to the horizontal linkage. The horizontal piece I have is straight and doesn’t have the D shape I saw in yours. I also noticed that the short vertical linkage on mine attaches to the pedal on the passenger side of the pedal, yours looks like it’s on the driver side. Here’s a crude pic from mine.

    Hope it helps

    51290B6D-FC76-417D-AD72-98F4F5B14AA1.jpeg
     
  5. 77mustard40

    77mustard40 SILVER Star

    Messages:
    1,254
    Likes Received:
    145
    Joined:
    Nov 28, 2010
    Location:
    Austin, TX
    Here’s one more shot of all my parts assembled before I started the conversion back to stock

    2F491EFB-05C4-4D04-A4AF-CAD8CE793B81.jpeg
     
  6. emac

    emac

    Messages:
    1,454
    Media:
    5
    Albums:
    1
    Likes Received:
    1,145
    Joined:
    Aug 28, 2015
    Location:
    SC
    yep, the ball on the gas pedal should be on the other side. The rest of it looks right. I have looked at a lot of various set ups trying to figure mine out, and I dont recall ever seeing a pedal like that. However, most of my issues were closer to the carb.
     
    RAGINGMATT likes this.
  7. RAGINGMATT

    RAGINGMATT Factory Focus-Point Mind-Set Approch..... Supporting Vendor

    Messages:
    3,908
    Media:
    21
    Likes Received:
    2,400
    Joined:
    Aug 12, 2007
    Location:
    East Coast
    U might have a RHD gas Peddal

    either way Your ball is on the wrong side and must be switches , U can take a drill but say 1/4 and Just Kiss the Rivit , , pull it out the flip it , put a nice spot weld on it and your good to go

    who restored your linkage ? they did a very nice job ......

    DSCN3300 - Copy.JPG DSCN3303.JPG DSCN3306.JPG DSCN3309.JPG
     
  8. brian

    brian SILVER Star

    Messages:
    9,063
    Likes Received:
    2,567
    Joined:
    Feb 7, 2003
    Location:
    lebanon,pa
    They used cables not linkage
     
    RAGINGMATT likes this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.