FJ60 Window Regulator help

Ocho77

SILVER Star
Joined
Jan 18, 2014
Messages
2,064
Location
Michigan
Website
www.op-art.guru
I’ve reinstalled this new window regulator 4 times, along with all new window runs. It rolls down halfway, and it catches on the bolt that holds the glass to the motor. If I take the glass out, the arms don’t reach out far enough to hit the bolt. What am I doing wrong? I'm driving myself crazy. This should literally take 20 minutes.

Video below.

 
Joined
Dec 2, 2002
Messages
16,949
Location
Helena MT
is it the correct sided regulator?
identical to the one you replaced?
 

Ocho77

SILVER Star
Joined
Jan 18, 2014
Messages
2,064
Location
Michigan
Website
www.op-art.guru
Yes, Toyota regulators come marked for LH and RH side.

I will say that I'm not replacing manual regulators. Changing my wife's FJ62 from power to manual windows. Ordered new regulators from Toyota. I'm at a loss.
 
Joined
Nov 13, 2020
Messages
377
Location
Dallas Texas
I have a 62 and when my door panels are off all the noises and rattles are like this. Is usually my inner seal isn’t holding in place or tracking as designed. I’m entry level though
 

CenTXFJ60

SILVER Star
Joined
Apr 1, 2014
Messages
3,685
Location
Spring Branch TX (Hill Country)
Something is definitely off there. Could the regulator be off on the mounting points by chance? Just put this one back in on a drivers door. It’s a dormant replacement
979D89B3-9353-4D4F-8929-20C0C413AA0F.jpeg
 

Ocho77

SILVER Star
Joined
Jan 18, 2014
Messages
2,064
Location
Michigan
Website
www.op-art.guru
T
Something is definitely off there. Could the regulator be off on the mounting points by chance? Just put this one back in on a drivers door. It’s a dormant replacement View attachment 3139453
Thanks for the pic, Jimmy! I’ll take a look when I get home. It works fine until I bolt the glass to it, then binds up halfway down.
 

CenTXFJ60

SILVER Star
Joined
Apr 1, 2014
Messages
3,685
Location
Spring Branch TX (Hill Country)
You
T

Thanks for the pic, Jimmy! I’ll take a look when I get home. It works fine until I bolt the glass to it, then binds up halfway down.
You got it Jonathan. The panel is off this truck I’m working on so glad to take other pics/measurements if that would help. Cell is 713-805-3962
 

Ocho77

SILVER Star
Joined
Jan 18, 2014
Messages
2,064
Location
Michigan
Website
www.op-art.guru
This is the driver side. The motor is installed correctly. Below is a picture of the same three bolts as @CenTXFJ60

If I remove the left bolt from the window channel, the window rolls up/down freely. However, below shows a video of how the window motor channel pulls away from the window with the bolt removed. Is there an adjustment for this?



This is a brand new Toyota regulator. I purchased new Dorman regulators before this and have had the same problem with both. The passenger side is the exact same issue. This is why I believe I'm doing something wrong, just have no clue what it is...

2B5F5ACA-B74A-4CEF-90B3-3B8019066B2B.jpeg
 

CenTXFJ60

SILVER Star
Joined
Apr 1, 2014
Messages
3,685
Location
Spring Branch TX (Hill Country)
If you bolt in the electric version regulator does it work correctly? This is a really weird issue as I’ve removed and installed more that a few and I literally slap them in. It’s hard to think anything could be mounted backwards or off to any degree. I don’t know of any adjustments. Does not mean there are not. And is that the same glass you were using with the electric version? If not, is there a chance that end cap at the bottom of the glass (that the regulator mounts to w/2 bolts) could have moved side to side? Long shot…just scratching for things on your behalf :).
 

Ocho77

SILVER Star
Joined
Jan 18, 2014
Messages
2,064
Location
Michigan
Website
www.op-art.guru
If you bolt in the electric version regulator does it work correctly? This is a really weird issue as I’ve removed and installed more that a few and I literally slap them in. It’s hard to think anything could be mounted backwards or off to any degree. I don’t know of any adjustments. Does not mean there are not. And is that the same glass you were using with the electric version? If not, is there a chance that end cap at the bottom of the glass (that the regulator mounts to w/2 bolts) could have moved side to side? Long shot…just scratching for things on your behalf :).
Electric ones worked great, just swapping for manual. I am using the same glass. Literally unbolted the electric motor and bolted in the manual, which is why I’m stumped. I have drill this weekend so it will have to wait til Monday.

Thanks for all of the help!
 
Joined
May 25, 2007
Messages
4,531
Location
Nashville
Electric ones worked great, just swapping for manual. I am using the same glass. Literally unbolted the electric motor and bolted in the manual, which is why I’m stumped. I have drill this weekend so it will have to wait til Monday.

Thanks for all of the help!

I just had a time putting a new regulator in my '83. I was having the same trouble with my glass binding up halfway down. Make sure the glass is seated in the vertical felt/rubber track on the inside of the door (closest to the body), as if that is off it will bind up since it's not "in" the groove. Also, like a few have said, the little bolts are very short, and I wouldn't crank them down just yet, especially the 2 that are the ones closest to the door lock.

Keep us posted man, good luck!
 
Joined
Jul 25, 2020
Messages
48
Location
Inverness, CA
If I remember correctly from last time I did this there is some adjustment of sliding the lower linkage side to side. Seems like that could help? As 2mbb mentioned is the metal bracket thats attached to the glass positioned correctly?
1665758210134.png
 

Users who are viewing this thread

Top Bottom