Old Truck for Old Guy (1 Viewer)

izzyandsue

Izzy
SILVER Star
Joined
Oct 31, 2014
Messages
5,513
Location
Charlotte, NC
Cruiserparts... I am sure many here had ordered from them. So I placed an orderTuesday, hoping to get stuff for the weekend, the told me they will not ship until Monday. This normal? Partsouq would have been cheaper and faster, so just wondering.
 
Last edited:

izzyandsue

Izzy
SILVER Star
Joined
Oct 31, 2014
Messages
5,513
Location
Charlotte, NC
Even the flanges were bad? Dang!
Well, went to install it today, front flange is perfect, rear only matches 2 bolt holes. I am glad I took it the truck there and they did the matuning, don’t know what happen but hope they will do right by me. Will let you know.

Meanwhile...new rear hose finally in! This old one was really bad. Last brake hose, next will be front pads.

A489FD86-C789-464C-8758-3BEC8E30087F.jpeg
 

izzyandsue

Izzy
SILVER Star
Joined
Oct 31, 2014
Messages
5,513
Location
Charlotte, NC
Thanks Al!

Got a chance to replace front brake pads, and found one side of the calipers are seized. Truck still brakes fine, but will replace the calipers soon. Also went out got 1/2” rubber mats to cover the rear floor, hope it helps dampen out some of the sound. 2 mats were enough to cover the whole, and the space under the seat.

BE816CA5-C2E0-47F5-88E6-15D09D538D60.jpeg
67B598DA-F44A-4569-9C36-90D9D5C155AA.jpeg
AE43DA8E-B67A-40F6-BA08-AF8E5F58D82E.jpeg
 

izzyandsue

Izzy
SILVER Star
Joined
Oct 31, 2014
Messages
5,513
Location
Charlotte, NC
Went to Driveline this morning, they installed the shaft using smaller diameter bolts. Got it up on the lift and it done. Also a good opportunity to check more of the undercarriage.

Water flow... this is the connections I have now, and the heater seems pretty much useless. The pump has the "oil cooler line" connected directly to the heater control valve, and the return to the other port on the pump (on top of the lower rad hose port). Need to figure out the puny heater, wondering if both return and intake to the heater are connected to pump outlets and just dead heading. Any thoughts appreciated.

fj43 water diagram connections.png
 

izzyandsue

Izzy
SILVER Star
Joined
Oct 31, 2014
Messages
5,513
Location
Charlotte, NC
Front calipers...the top caliper bolt was upgraded to 1/2 bolt from 12mm. Why? Who knows....but that required enlarging the diameter of the caliper hole. I had forgotten I had an old drill press in the corner, so all I needed was a decent bit and some way to hold the caliper in place while drilling. Anyway, it worked and new calipers and pads installed.

1610819714940.jpeg
905CE45D-AC9B-445D-AA98-E5E6FAD479E9.jpeg
C225497A-090F-4833-AE9B-CAD7EAD7DE4B.jpeg
3B5F8029-3F21-411C-86A6-BB6BE8D4C7E0.jpeg
 

izzyandsue

Izzy
SILVER Star
Joined
Oct 31, 2014
Messages
5,513
Location
Charlotte, NC
This is the hose for the PCV, the only hole that connects to the intake from the valve cover but had no valve. The fj40 grommet is way to large for the hole, so using a 5/8” coolant hose and splicing the valve in the middle to hopefully create the same effect. Otherwise the valve cover would just be open to the intake.



1610890475234.jpeg
 

izzyandsue

Izzy
SILVER Star
Joined
Oct 31, 2014
Messages
5,513
Location
Charlotte, NC
Speedo. Got the parts from Cruiserparts today and Installed the speedo gear. Looks like all I had to do was install the gear shaft, none of the seals. Anyway, works nice now, all in Km but that’s not hard to translate, checked speed against gps speedo and all looks good.

1610923351603.jpeg
 

izzyandsue

Izzy
SILVER Star
Joined
Oct 31, 2014
Messages
5,513
Location
Charlotte, NC
Almost 2 weeks to ship, but all parts got here. Will they fit? Don’t know yet. The rear spring plate doesnt, it’s a lot smaller. So likely will take the old one out and machine a thread on it
 

Users who are viewing this thread

Top Bottom