Nothing Works! RPM will not increase above 2000 in D (1 Viewer)

Joined
May 16, 2016
Messages
37
Location
Doha, Qatar
A month ago, I took my Cruiser to a mechanic my local off-road club had recommended. He said that the fault was with my neutral safety switch. He pointed out that none of the dash gear indicator lights were working except R and L. He also pointed out that the R and L gears work properly. In 2 and D, the RPM does not ever increase beyond 2000, as if it had a limiter.

I purchased a brand-new neutral safety switch from Toyota and gave it to the mechanic to install. Now all of my dash indicator lights were working! But in D, the RPM will still not increase above 2000. In 2, however, the gear was fixed after the installation of the new switch. The transmission shifts normally, but I get sluggish acceleration when in D. The mechanic now thinks it's a problem in the transmission itself, and wants to rip it out to inspect it fully. Of course this will cost me thousands of dollars, and weeks at the shop. I just wanted to post here to see if you guys have any ideas before leaving it to him. Obviously I'm not very mechanically inclined, but I love the truck, and am dedicated to keeping it.

Thanks in advance for your help.
 
Joined
Aug 26, 2011
Messages
1,039
Location
Riverside, CA
 
Sounds kind of like the cat might be clogged. Might be worth it to do an exhaust back pressure test before you spend a ton of money on the trans.
 
Joined
May 16, 2016
Messages
37
Location
Doha, Qatar
Sounds kind of like the cat might be clogged. Might be worth it to do an exhaust back pressure test before you spend a ton of money on the trans.
My RPM will only stop at 2000 in D, though. Don't you think if it was the cat I would get low RPM on L and 2 too?
 
Joined
Aug 26, 2011
Messages
1,039
Location
Riverside, CA
 
My RPM will only stop at 2000 in D, though. Don't you think if it was the cat I would get low RPM on L and 2 too?
I've worked on a couple cars/trucks that did what your 80 is doing that ended up being bad cats. They would rev fine in P or N and in lower gears be ok but once they shifted to their highest gear power would fall off and they wouldn't rev right anymore.
 
Joined
May 16, 2016
Messages
37
Location
Doha, Qatar
I've worked on a couple cars/trucks that did what your 80 is doing that ended up being bad cats. They would rev fine in P or N and in lower gears be ok but once they shifted to their highest gear power would fall off and they wouldn't rev right anymore.
In D, the RPM never goes above 2000. Even in first and second, while in D, the RPM will not move beyond 2000, as if it had a rev limiter or something.
 
Joined
Aug 26, 2011
Messages
1,039
Location
Riverside, CA
 
In D, the RPM never goes above 2000. Even in first and second, while in D, the RPM will not move beyond 2000, as if it had a rev limiter or something.
I thought you said in your other post it would rev ok in the L and 2. This sounds even more like a clogged cat to me then since it won't rev above 2K in any gear.
 
Joined
Mar 30, 2009
Messages
606
Location
Indiana
 
 
Transmission solenoid(s) or ATF fluid level? Mine didn't want to rev and found the transmission was a couple of quarts low because PO didn't know how to check it. Also had two bad solenoids.
 

SmokingRocks

I bought a Cruiser to keep miles off my Cruiser
Joined
Oct 6, 2014
Messages
3,245
Location
Colorado
 
is it a hard cuttoff at 2k rpms? like a rev limiter fuel cut? or does it just run out of steam?

Also you check your transmission fluid by getting it warm, putting it in neutral let the engine idle and check the dipstick.
 

TrickyT

Hate that mud...
SILVER Star
Joined
Apr 1, 2006
Messages
1,498
Location
Mill Valley, CA
 
 
Since your 80 is not from the north american marketplace it may be equipped with different components then most of us are used to. For example, are we talking about a A442F transmission with mechanical lockup converter? (That's what was used in NA 80s in 1994.) Any other potential differences that you know of?

On 1995-97 80s (don't know if 1993-94 are the same), the ECU doesn't know the difference between when the A/T is in park versus drive, other than that the speed sensor shows movement. So one question, can you rev above 2,000 when in park and neutral? And another: when in D can you tell if the A/T starts out in 1st gear? And does the speedometer work correctly?
 
Joined
May 16, 2016
Messages
37
Location
Doha, Qatar
I thought you said in your other post it would rev ok in the L and 2. This sounds even more like a clogged cat to me then since it won't rev above 2K in any gear.
it revs okay in L and 2. In D, though is doesn't increase above 2000 no matter what gears it is in.
 
Joined
May 16, 2016
Messages
37
Location
Doha, Qatar
Since your 80 is not from the north american marketplace it may be equipped with different components then most of us are used to. For example, are we talking about a A442F transmission with mechanical lockup converter? (That's what was used in NA 80s in 1994.) Any other potential differences that you know of?

On 1995-97 80s (don't know if 1993-94 are the same), the ECU doesn't know the difference between when the A/T is in park versus drive, other than that the speed sensor shows movement. So one question, can you rev above 2,000 when in park and neutral? And another: when in D can you tell if the A/T starts out in 1st gear? And does the speedometer work correctly?
I'm not sure of my transmission model, how do I check that? The only difference that I know of that's kind of related is that mine isn't full-time 4WD from the factory.
I can rev the engine just fine in N and P. When in D, I can tell that it starts in first and shifts normally as speed increases. My speedo doesn't work correctly. When i move at any speed, it shows 80 km/h, and I'm stopped it sits at 0. Those are the only 2 figures it shows.
 
Joined
May 16, 2016
Messages
37
Location
Doha, Qatar
is it a hard cuttoff at 2k rpms? like a rev limiter fuel cut? or does it just run out of steam?

Also you check your transmission fluid by getting it warm, putting it in neutral let the engine idle and check the dipstick.
It is a hard cutoff at 2k RPM. As if there is a rev limiter exactly.
I will check the tranny oil like you said and get back to you.
 
Joined
May 16, 2016
Messages
37
Location
Doha, Qatar
One of the experienced guys at my local wheeling club says that it's an engine issue in his opinion, after driving my truck. He's saying the engine is clogged and needs an overhaul. What do you guys think?
 
Joined
Dec 26, 2014
Messages
130
Location
Lubbock Texas
What does he mean by "clogged?" That's not a diagnosis. You said it revs fine in L and 2, then it doesn't need an overhaul.
 
Joined
Jan 3, 2015
Messages
359
Location
Lower Alabama
 
Ahhh, the old "engine is clogged" diagnosis. The quick fix is Xylene followed by 15% HCl. You're gonna wanna do a xylene flush first to wash the oil off the surfaces. I'd say 6 barrels should do it. Then follow with the HCL to help dissolve the scale and salt build up. give or take 15 barrels on that one but don't let that HCl hang out too much or all your pistons are gonna be communicating and the epoxy injection to repair that is always a hit or miss.

That usually works on a typical low pressure 200F+ well(around the same op temp as our trucks), so its gotta work on a "clogged" engine.

On a more serious note, Id look at your throttle cables and throttle body to make sure your getting full movement. Maybe work the throttle by hand while someone watches your tach. You could have broken strands in your throttle cable that can pull fine in the beginning of the acc pedal range but the remaining strands "stretch" as you put more tension on it, never giving you full motion at the throttle body.

And don't put HCL in the motor.
 

SmokingRocks

I bought a Cruiser to keep miles off my Cruiser
Joined
Oct 6, 2014
Messages
3,245
Location
Colorado
 
  1. Your engine revs freely in neutral and Park suggest your engine is not 'clogged'. What ever that means.
  2. Does your check engine light come on briefly when you turn the key to the on position? (This is called bulb check, if it's not coming on then your bulb is burnt out)
  3. what engine is in your cruiser?
  4. Your transmission code should be printed on the sticker on the drivers side door threshold (where tire pressures and gross vehicle weight are also listed). All US 80's had 4 speed autos, from 93-94 the transmission was the A442F, 95-97 came with the A343.
  5. Any other issues with the rig? Has it been through a water crossing recently?
  6. Had the rig been modified? Can you tell if the previous owner did his own electrical work? (In line fuses, wire nuts, butt connectors. Are all of the fuses in the fuse boxes the right amp rating for their device?)
Since you are having an issue with your speedo I would suspect it's switched your ecru into limp mode.
 
Last edited:

Formulaonehd

Dirty 30 HZT
Joined
May 22, 2016
Messages
462
Location
Pilbara Region Western Australia
zapdescribe ost: 10599484 said:
Transmission solenoid(s) or ATF fluid level? Mine didn't want to rev and found the transmission was a couple of quarts low because PO didn't know how to check it. Also had two bad solenoids.
Could you describe the symptoms you were having with the bad solenoids and how much it cost to do the job?
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom