LC & LX470 Tesla Style Screen Radio Upgrade with Climate Control: General Discussions

Joined
Dec 5, 2016
Messages
2,182
Location
DC
Hello folks, i am about to hop on board with this. I found the radio here on this site



Couple questions, i have an iphone, do i need to buy the Carplay USB Dongle to be able to have apple car play work, is it built in or i need to buy that thing? The one thing i hate the most is static noise is that present with these units? I bought something for my 2001 LC awhile back and the buzzing was killing me i threw it out.
 
Joined
Apr 29, 2020
Messages
101
Location
socal
Hello folks, i am about to hop on board with this. I found the radio here on this site



Couple questions, i have an iphone, do i need to buy the Carplay USB Dongle to be able to have apple car play work, is it built in or i need to buy that thing? The one thing i hate the most is static noise is that present with these units? I bought something for my 2001 LC awhile back and the buzzing was killing me i threw it out.
you don’t need the dongle, the PX6 has the wireless CarPlay built in to my knowledge. I ordered mine with it and it works without it. I have some buzzing that I need to tune out of my amp but I haven’t gotten around to adjusting it with the seat in place. Note I have a aftermarket amp so your factory amp might be different
 
Joined
Dec 5, 2016
Messages
2,182
Location
DC
Is that website a good source to buy from? Looks like they're based out of CA per their "Contact Us" button.
 
Joined
May 16, 2019
Messages
23
Location
North Dakota
There is also this one from another thread:


Other thread -> New Tesla screen

I have no experience with either unit, but noticed that the physical buttons at the bottom of this one are different (AC controls vs. the factory style controls).
 

ramangain

SILVER Star
Joined
Feb 6, 2020
Messages
680
Location
the Throne
SOOOOO what I am gathering is I cant put one of these in my 2001 Lx470 as it wont control everything, so its pointless.
I don't think that blanket statement is true. You may need additional isolation here and there to ensure spurious signals don't affect other signals. This is not uncommon with custom wiring ganging together electronics that were not tested together as a subsystem.
 
Joined
Nov 22, 2014
Messages
29
 
I'm half way through the installation of a PX6 in my -05 HDJ100 - just preparing some future wiring into the glovebox before I start the dreaded stuffing of cables.
The installation guide and the input from people here has been very valuable, so a big thanks to everyone who's chimed in on the forums with questions and answers.
I did scratch my head with the cabling at first, but it is really just a matter of connecting the connectors that fit.
I haven't noticed any issues but I have only tested it with the gut open. I ordered three weeks ago from Aliexpress "Autostereo store" (store # 1965026) and it took them only 3 days to ship, 3 days shipping to Norway. DHL fcked up the delivery locally again and sat on the package for 10 days, but that's a different story. The Aliexpress seller contacted me to check if I had whatsapp - in case I needed support.

Finally, I have a few questions about the signal cables in the wiring harness. I've tested a little tonight and they really confuse me. Maybe some of them need to be activated in the unit somehow? Maybe some of them are inputs not outputs?

These are the single cables labeled:
"Back" - zero volts regardless what I do, ignition off, acc on, car running, gearbox in reverse.
"Amp" - I assume this is for amplifier on. Also zero volts regardless what I did.
"Brake" - 3.3 volts regardless what I do. Maybe it goes to zero after some time.
"IG" - I thought this could be an ignition signal output. Zero volts regardless what I do.
"Airbag open" and "Airbag closing" - I didn't test these, what are they for?

Then theres the "Aux in left/right" and "Camera" on the main harness. What are these compared to the dedicated plug with all the video and sound in and outputs?

Oh, I wired up the external mic but people said the sound was worse with it. Almost like the signal was amplified too much.
 
Joined
Jul 21, 2010
Messages
532
Location
Northern VA
 
 
I STRONGLY suggest avoiding Rhino...

They are non responsive and will give you the runaround until you cannot claim your credit card.

Once the window closes... You'll never hear from them again.
 
Joined
Jun 26, 2019
Messages
11
Location
Phoenix, Arizona
This is very similar to my experience buying off AliExpress (the story is somewhere earlier in this thread). Basically, they convinced me to drop my PayPal dispute, only to find out that it was just a trick, leaving me with no recourse. Buy from a company with American customer service, or you're pretty much on your own. Unfortunately, it looks like we both learned that the hard way. I ended up paying for two units just to get one that worked, and I never got the refund for the one that didn't.
Same issue here, they told me that I would get support after a holiday and then after an engineer's returning, only to find that I was outside the dispute window and Ali would do nothing for me. Avoid Ali!
 
Top Bottom