From Poverty Packin to Betty White: 1992 HZJ80 (1 Viewer)

davegonz

Keeping it Weird
SILVER Star
Joined
Sep 15, 2004
Messages
9,087
Location
Austin, TX
Looks like I missed the air intake side. I did reinstall the intake with new gaskets. The fuel lines went in after that.

1605589590440.png


1605589605363.png
 

davegonz

Keeping it Weird
SILVER Star
Joined
Sep 15, 2004
Messages
9,087
Location
Austin, TX
So far so good. I paired it with a Victron solar controller and a 100W panel. Works great.

1606165630284.png
 

davegonz

Keeping it Weird
SILVER Star
Joined
Sep 15, 2004
Messages
9,087
Location
Austin, TX
Quick update. @bottombracket and I were able to finally purge all of the air out of the injection pump and injectors and got her fired up! I swear I tried all the tricks (remove glow plugs, crack injectors) until the battery died and had to recharge it. It's done and I can move forward.

 

davegonz

Keeping it Weird
SILVER Star
Joined
Sep 15, 2004
Messages
9,087
Location
Austin, TX
Oh, forgot to mention the center console. I really wanted a 10 inch wide Tuffy, but they are out of stock until March. So, I picked up a cheap $85 Smittybilt with the stereo slot. I'm going to get that installed soon.
 

davegonz

Keeping it Weird
SILVER Star
Joined
Sep 15, 2004
Messages
9,087
Location
Austin, TX
Here's a pic of the console. @bottombracket still has some of the Kevlar cloth from the door cards so the plan is to cover the pad to match.

As you can see, the cupholder metal gets in the way and will be removed so I can slide it up more. I might 3D print a cupholder. We'll see.

1607914092032.png
 

davegonz

Keeping it Weird
SILVER Star
Joined
Sep 15, 2004
Messages
9,087
Location
Austin, TX
I was hoping to drive this around during the Christmas break, but couldn't because something was wrong. It wouldn't build up boost and it sounded like crap!! I decided to leave it be while we were in south Texas with my mother-in-law. I really bugged the hell out of me thinking that I might have screwed up the crank bearings or something. Well, upon further inspection and some help from @aljollano we were able to find some exhaust and boost leaks due to me just forgetting to tighten things down. It still wouldn't boost right and still sounded like crap (but slightly better). Turns out the exhaust manifold I bought had a hole that I didn't see due to me putting the exhaust manifold shield back on. Man, don't you love easy crap like that!

1610488964369.png
 

davegonz

Keeping it Weird
SILVER Star
Joined
Sep 15, 2004
Messages
9,087
Location
Austin, TX
I also finished the mounting bracket for the center console. I will be 3D printing some custom cup holders this week and integrating them in the front of the console.

1610489417128.png


1610489439939.png
 

davegonz

Keeping it Weird
SILVER Star
Joined
Sep 15, 2004
Messages
9,087
Location
Austin, TX
Some observation on the turbo and overall performance:
  • Can boost to 20 psi easily.
  • EGT's never go over 1000F. Mostly stay 800-900F.
  • Can cruiser 65-75 with 8-10 psi of boost.
  • Seems fast, but not as fast at take off as Crusty, my old FJ60 with the turbo'd 1HZ. I think it might be due to the 80 being heavier and the 4.10 gears (Crusty had 3.7x's).
  • Overall, I'm really happy with the turbo. It was economical especially considering it was brand new.
 

Users who are viewing this thread

Top Bottom