FJ80 No start!! Have read a ton of articles and need help! (1 Viewer)

Joined
Mar 29, 2021
Messages
1
Location
Eugene Oregon
Hey there, I am a long time reader of this forum and appreciate all of the resources that come from this place. I have a 1991 FJ80 with 300,XXX miles on it. I have recently purchased this 80 as a parts rig for my original 80. My original 80 is currently getting the front end rebuilt and 4.88's so I am excited about that. However, I purchased this other 1991 FJ80 as a parts rig and when I got it home, I found that it was way to nice to chop up and use for parts. This thing needs to live and be used by another enthusiast. The previous owner stated that he drove the thing to work, and when he got off of work, it had no power to the key. He sent it into the shop and the shop put an entirely new wiring harness in it. This process took some time so he had purchased another land cruiser in the mean time. When he got this one back, he did not need it and it sat for well over a year. I then purchased it and brought it home.

I have since, drained and replaced the gas, the fuel filter, and now the fuel pump. I have also replaced the fusible link at the battery and put a new EFI relay in the under-hood fuse box. When I was first trying to start it, I did not have the check engine light coming on with the key on. I am now getting that with the replacement of the EFI relay.

Here in lies the problem, it still does not start. It will turn over and start to sputter and begin to crank faster as it sputters more. I will then release the key from the "Start" position and it will sputter a few more times before it ultimately dies. I have checked and confirmed that it is getting fuel, it is getting good and consistent spark, and there is no blockages that would prevent it from getting air. Is there something else I am missing. I have replaced the stator with the one from my first FJ80, which I know to be good, and saw no change.

Is there anything else that would be suggested? Is there other fusible links that I could replace that would cause a no start situation? Thankfully this is not my primary FJ80 but the fact that it does not run when it should, bothers me. Please let me know any ideas or insight. I am located near Eugene Oregon.
 

Users who are viewing this thread

Top Bottom