Automatic transmission cooler barb corroded

Discussion in '80-Series Tech' started by nukegoat, Apr 27, 2017.

  1. nukegoat

    nukegoat

    Messages:
    3,093
    Likes Received:
    2,794
    Joined:
    Apr 11, 2013
    Location:
    San Jose, CA
    Anyone else had this happen? The lower barb on my at cooler is almost corroded through. The top one looks completely fine. Is there a drop in new replacement that anyone has used instead of the oem?

    @beno whats a new one of these cost?
     
  2. NLXTACY

    NLXTACY Wits' End Supporting Vendor

    Messages:
    22,981
    Media:
    23
    Albums:
    2
    Likes Received:
    15,199
    Joined:
    Dec 7, 2007
    Location:
    West Hills, CA
    I found some at SOR locally...thankfully.
     
  3. nukegoat

    nukegoat

    Messages:
    3,093
    Likes Received:
    2,794
    Joined:
    Apr 11, 2013
    Location:
    San Jose, CA
    Had yours started to go too?
     
  4. NLXTACY

    NLXTACY Wits' End Supporting Vendor

    Messages:
    22,981
    Media:
    23
    Albums:
    2
    Likes Received:
    15,199
    Joined:
    Dec 7, 2007
    Location:
    West Hills, CA
    Actually no, I stupidly threw mine out with the OEM radiator. Doh!
     
  5. NLXTACY

    NLXTACY Wits' End Supporting Vendor

    Messages:
    22,981
    Media:
    23
    Albums:
    2
    Likes Received:
    15,199
    Joined:
    Dec 7, 2007
    Location:
    West Hills, CA
    Although I am 100% sure there is an AeroQuip replacement. I was out of time/patience so I went the SOR route.
     
    Last edited: Apr 27, 2017
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.