A night in the Green Swamp: Lotarp 100 busted front diff in Richloam Wildlife Management District

Joined
May 24, 2016
Messages
68
Location
78664
Oh dear, that doesn't sound healthy at all.

You can pull the diff drain plug and look for metal.

I'm hoping it's just a spider gear and not a tooth missing but that video of you putting it in drive sounds rough. Do you think thats because you have the rear tires still on the ground?
 
Joined
Oct 27, 2014
Messages
1,948
Location
Florida
Hey man, great story and sorry bout your trip. Hit me up next time your heading out. Have you check the clubhouse section for florida landcruiser association? There is a guy on there [dont recall name] with cruiser parts. worth a try.

As for tires i run kenda mt 33's. They are cheap, but have given me great traction. Took them to hard rock july 2nd with rain all day and no loss of traction. No weird issues so far.

https://www.amazon.com/Kenda-Klever-KR29-Terrain-Radial/dp/B008BWNX44/ref=sr_1_1?ie=UTF8&qid=1469672130&sr=8-1&keywords=kenda+klever+mt+285+75+16
 
Joined
Jul 25, 2016
Messages
60
Location
Lakeland, Florida
Also, sound persists when in neutral w/ transmission and in neutral with transfer case, which makes me think again it's driveline related BELOW the TC/Tranny; just no idea why the grinding putting into gear.
 
Joined
Apr 26, 2010
Messages
3,402
Location
Raleigh, NC
Great story, and glad you got out.

Kinda lame that some mud destroyed something in the driveline. doesn't speak too well to the robustness of the LC these days
 
Joined
Jul 25, 2016
Messages
60
Location
Lakeland, Florida
So finally found out that it was the front diff. I'll be asking to see the parts when it's replaced. Found a donor diff locally out of an 02 for 600. Going to have the CV boots redone and repacked while they're out. Thanks for reading, commenting, and helping! I'll be more careful in the future!
 
Top Bottom