2003 LC Tesla Screen Install Write-Up

Joined
Mar 1, 2020
Messages
3
Location
Atlanta, GA
Now I have to go look up cameras
@mistered123 Assuming this is the same one you bought over email? Looks simple enough to add a camera. Anything else you had to add in? I might just have to go for it and see when it gets here.

 
Joined
Jan 1, 2019
Messages
79
Location
Centennial, Colorado
@mistered123 Assuming this is the same one you bought over email? Looks simple enough to add a camera. Anything else you had to add in? I might just have to go for it and see when it gets here.
Yep that looks like the same one that I ordered - other than Px3 vs Px6.

I also ordered a wired carplay adapter. I tried a wireless one first and it was terrible. This is the one that I have now and it works "ok". Quite often it won't register the first time I plug the phone in and I'll have to disconnect and re-connect the phone, but not a huge issue for me. But I suspect any car play adapter designed for android systems will work fine.
 
Joined
Jan 9, 2020
Messages
128
Location
TX
On my 2003, I have not had to alter the wires on the nav system. Radio works fine out of all 5 speakers.

The boot up time is annoying.(25sec) I have a VERY slight hum. Tried to ground to the same place as the stock amplifier, no help. Turns out these trucks with stock amp have a floating ground. Only way to eliminate hum is to pull the stock amplifier and replace or bypass. You never hear the buzz over roadnoise, so I will leave it.

I have a dongle for Apple car play-works great. Playing back texts through apple car play is a bit garbled( a known issue with CarPlay)- regular turn by turn navigation voice prompts through apple maps is clear.

I find the radio more responsive than I thought it would be. It sounds much better than stock to my ears. Bluetooth works perfect.

I have no Idea how to get the music from USB onto the unit. I know the USB works because my apple car play dongle is connected to the usb connector and it works fine. When I connect a USB drive to the other USB connector the usb drive lights up-but I can't figure out how to get the radio to recognize the drive and move the music from the USB drive to the radio. Must be something simple. I am an apple guy, and have never used the Android OS
Do you have the wired carplay dongle or wireless one? I’ve been trying to decide whether or not to get wireless.
 
Joined
Jan 9, 2020
Messages
128
Location
TX
Well just installed my PX6 Android 9.1 fastboot head unit.

This good news is:
  1. A/C works.
  2. Boot time is under 5 seconds after initial install.
  3. The compass works

    The bad news is:
  4. I can’t get it seated in the harness correctly. Too many wires.
  5. I’m not sure how to route the usb cables into the glove box. (Or anywhere for that matter. They keep getting stuck so they are stuck behind the HU.)
  6. My dash lit up like a Christmas tree.
  7. Only my front 2 speakers work.
  8. My antenna won’t extend and my radio doesn’t work.
  9. Bluetooth connects for phone calls, but not for music. Sound is terrible for phone calls.
  10. I have a yellow Lamborghini background
  11. It thinks I’m driving up a mountain at a 30 degree incline.

    need to read back through all of these threads for tips. Anyone have any advice off of the bat?

    4043AE75-9899-4A8D-B10D-2C15F4A4B476.jpeg
 
Joined
Jan 9, 2020
Messages
128
Location
TX
Well just installed my PX6 Android 9.1 fastboot head unit.

This good news is:
  1. A/C works.
  2. Boot time is under 5 seconds after initial install.
  3. The compass works

    The bad news is:
  4. I can’t get it seated in the harness correctly. Too many wires.
  5. I’m not sure how to route the usb cables into the glove box. (Or anywhere for that matter. They keep getting stuck so they are stuck behind the HU.)
  6. My dash lit up like a Christmas tree.
  7. Only my front 2 speakers work.
  8. My antenna won’t extend and my radio doesn’t work.
  9. Bluetooth connects for phone calls, but not for music. Sound is terrible for phone calls.
  10. I have a yellow Lamborghini background
  11. It thinks I’m driving up a mountain at a 30 degree incline.

    need to read back through all of these threads for tips. Anyone have any advice off of the bat?

    View attachment 2245325
So while I am posting questions in both threads, I will only post fixes here since I have an 03 and this is an 03 specific thread.

4. Regarding fit, after a significant amount of pushing and pulling on cables I was able to make it fit... well sort of. It's still not a great fit, but I think its as good as its going to get.
5. I finally figured out how to route the USB cables to the glove box after figuring out how to remove the glove box. It's pretty simple. Just look for the two screws on the bottom of the box.
6. The lights.... well, they just went off... I have no idea what happened here.
7. No solution for the speakers yet. I don't want to splice. I am reaching out to Phoenix about a new harness since that seemed to solve some people's issues.
8. Antenna still wont extend and radio doesn't work. See 7 for same solution.
9. Well after plugging in my phone into the USB it connected with my HU. And while I couldn't find the app for CarPlay it spontaneously loaded up after connecting to the phone. Then I unplugged the phone from the USB.... and carplay kept working... wirelessly. So, I have built in wireless carplay now. Got back in the car today and it automatically went straight back to the carplay screen. Playing music works well via this connection.
10. Still have a yello lambo load screen.
11. Um... I double tapped the 30 degree icon and it leveled out... so ... there's that.

So most of my issues magically fixed themselves. My list is now cut down to mostly stereo/radio issues.

1. Only front 2 speakers work and sound is atrocious.
2. Radio doesn't work and antenna wont extend.
3. Still have the lambo load screen.

So still waiting to hear back from Phoenix Auto on a new wiring harness. Oh and I found this! One cable from the car that doesn't have a home. Anyone know what this is?

Next up to load the ODB wireless connector. After that, backup camera install.
 
Top Bottom