yes, I managed to mangle it again . . . (1 Viewer)

DSRTRDR

I can mangle anything ...
SILVER Star
Joined
Jan 4, 2005
Messages
15,178
Location
Baton Rouge, LA and Fountain Hills, AZ
 
 
 
cruising along at 70 on the highway, a bit more noisy running than normal, and then a sudden SNAP - after which it ran quieter and smoother :confused:

luckily, I was on my way down an off-ramp - at the stop light, steam came out of the hood vents :eek: - radiator fluid all over :rolleyes: :rolleyes: :rolleyes:
water pump 1.jpg
 

DSRTRDR

I can mangle anything ...
SILVER Star
Joined
Jan 4, 2005
Messages
15,178
Location
Baton Rouge, LA and Fountain Hills, AZ
 
 
 
never leaked in 6 years

the second and third pic show scores on the propeller and on the inside of the housing, respectively - the shaft is moving around sideways and parts are rattling in there now :doh:
water pump 2.jpg
water pump 3.jpg
 
Joined
Apr 5, 2006
Messages
13,859
Location
NorCal
 
 
At least you didn't break off bolts in the block. Easy fix. :banana: Did you have to get towed though? That sucks?
 

Cdaniel

Undocumented Mechanic-Not CDAN
SILVER Star
Joined
Sep 29, 2004
Messages
2,639
Location
AZ
 
 
 
Better in town than out in the back country. :)

Good luck with an easy fix.
 

DSRTRDR

I can mangle anything ...
SILVER Star
Joined
Jan 4, 2005
Messages
15,178
Location
Baton Rouge, LA and Fountain Hills, AZ
 
 
 
new pump is already on the truck - runs just fine - lucky to have avoided greater carnage :D

yes, AAA Plus - towed it to where I wanted it, no questions asked - they came within 40 minutes of my call - real easy
 

Poser

Oh...Durka Durka Durka.
s-Moderator
Supporting Vendor
Joined
Oct 1, 2003
Messages
20,451
Location
MN
 
 
 
Your fan did not go through your radiator or hood...you do not have any problems.




:lol:
 

DSRTRDR

I can mangle anything ...
SILVER Star
Joined
Jan 4, 2005
Messages
15,178
Location
Baton Rouge, LA and Fountain Hills, AZ
 
 
 
anybody's guess

if the motor was put in by the same PO who put the lockers in, it has been in there since '89 - the water pump had no TEQ stamp, so prolly changed at least once since then

I got the truck in 12/2004 - likely didn't put more than 15,000 miles on it myself
 
Joined
May 26, 2005
Messages
7,831
Location
Phoenix
 
 
 
Shame on you Claudia. That's a known failure in that style pump. I can't believe you didn't replace is as PM. I believe there's a thread somewhere about getting Toyota to do a recall on that pump, look into that.









I can't wait 'till you get an 80 series. :flipoff2:
 

Cdaniel

Undocumented Mechanic-Not CDAN
SILVER Star
Joined
Sep 29, 2004
Messages
2,639
Location
AZ
 
 
 
Don't stray to the dark side Claudia. The 40 force is strong with this one. Listen not to the sith, stay with us. :cool:

I can't wait 'till you get an 80 series. :flipoff2:
 

DSRTRDR

I can mangle anything ...
SILVER Star
Joined
Jan 4, 2005
Messages
15,178
Location
Baton Rouge, LA and Fountain Hills, AZ
 
 
 
:Di think for the $ i would put on new one on and skip the tow .
the tow didn't cost me anything - AAA :doh:

the new pump is on there and works fine - I wheeled it today :steer: ;p

Don't stray to the dark side Claudia. The 40 force is strong with this one. Listen not to the sith, stay with us. :cool:
yeah, there is only so much left to mangle by now :lol:
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom