Installed Poly Performance rear axles today; also basic RTI shots

Joined
Apr 12, 2005
Messages
1,729
Location
Seattle, WA
Website
www.4wdtoyotaowner.com
Got a set of Poly Performance full floater rear axles for our 1995 FZJ80 and put them in today. Replaced all seals with units from CDan, cleaned and repacked the bearings, etc etc. No instructions, but an easy install for sure. Hardest part I guess was getting the spindle oil seal to seat correctly and that wasn't really hard (although there is an SST for it). Dan's suggestion for the inner lock rock ring SST was good (as usual) much better than hammer and punch!

Now have Longfield front axles and Longfields, rear Polys, and Yukon 5.29s.

Then, totally unrelated, did a basic RTI test in the yard and also in some rocks. Just for shizaks and giggles. Usual arbitrary shots, but fun. Crushed one panel of the ramp with the Cruiser's weight!

Photos here:

http://www.4wdtoyotaowner.com/SnowRun.html
 

MaddBaggins

Remember the KnightRider!
Joined
Feb 22, 2005
Messages
3,548
Location
The Old Pueblo
Visit site
Are you keeping track of the mileage on the Longs and the Poly's? Do you plan on running them till they wear out? I'd be interested in seeing some real world mileage #'s on the chromoly stuff.

Nice pics. :cheers:

Oh, and do you trailer the rig or drive from place to place?
Thanks
 
Last edited:

GXO

GXOR
Moderator
SILVER Star
Joined
Feb 7, 2002
Messages
11,159
Location
Woodstock, GA
Website
gxor.org
having longs and polys in have given me such peace of mind...till i break em! :)

I need to go to 5.29s, but waiting for my diffs to eat themselves and swap in ARBs F&R at the same time.
 
Joined
Apr 12, 2005
Messages
1,729
Location
Seattle, WA
Website
www.4wdtoyotaowner.com
Are you keeping track of the mileage on the Longs and the Poly's? Do you plan on running them till they wear out? I'd be interested in seeing some real world mileage #'s on the chromoly stuff.

Nice pics. :cheers:

Oh, and do you trailer the rig or drive from place to place?
Thanks

Thanks Alvin. I do have the original mileage on my receipt for the truck when I purchased it in 2005; I'll have to look it up. I think it was 148K.

Yes, the plan is to use 'em until they start the dreaded clicking (the Longs) and the axles essentially forever. My hubs and seals were in great shape, by the way, despite many mud runs here in rainy Washington. I think the axles were pulled in the past however because there as no paper gasket, only RTV between the end of the axle and the hub.

I don't own a trailer, it's a driver only, and not a bad one except for fuel economy. Love 80s!

We'll be debuting some new surprises for this truck soon.

Dave
 

Users who are viewing this thread

Top Bottom