HJ47 Glow Problems

Joined
Jul 12, 2014
Messages
37
Location
San Francisco Bay Area
I posted this in the 40 series tech section, but someone suggested I post it here as well... I know there are a lot of threads about glow plug issues, I've read a few of them today and they've been very helpful. Just wanted to throw this out there in case anyone has ideas about something I can check before ordering new parts...

I have a HJ47 with a 2H that had been sitting idle for the better part of a year, it hadn't been turned over at all. Today when I tried to start her up she turned over but would not start. The glow light went on as usual for about five seconds, but upon start it just cranked and cranked. I noticed that I couldn't hear the glow relay clicking like it's supposed to, and upon putting a multimeter on the busbar I verified that the relay was not putting any voltage on the glow busbar even though the light on the dash was illuminating. I used a heavy duty wire and manually glowed the plugs from the battery terminal, after which the engine started right up like a dream.

I'm guessing from this experiment that the relay/solenoid in the glow timer may be at fault? Anyone out there have any other ideas of things I should check before ordering another one? I ask because they're not the cheapest things in the world... I uploaded a photo and the glow timer is there on the left, does anyone know what the little box on the right is for? Where is the actual relay that the glow timer energizes?

Photo Dec 11, 4 29 53 PM.jpg


Thanks very much for any help!
 

tlaporte

SILVER Star
 
 
Joined
Dec 17, 2003
Messages
567
Location
Pasadena, CA
I'm guessing from this experiment that the relay/solenoid in the glow timer may be at fault? Anyone out there have any other ideas of things I should check before ordering another one? I ask because they're not the cheapest things in the world... I uploaded a photo and the glow timer is there on the left, does anyone know what the little box on the right is for? Where is the actual relay that the glow timer energizes?
Based on location and wiring, I believe that that's the Starter Relay, though the wiring diagram suggests the four wires should be W-L, B-W, W-L, and W-B, whereas your picture shows W-L, B-W, W-B(?), B-W, so the pair of wires on the right hand connector don't match with what the diagram says it should be, FWIW.

There is a great thread started by @bgennette about the SuperGlow system. There's lots of info also provided by @lostmarbles in that thread that gets into the hows, whys and whats of SuperGlow.

There is also this thread, which is about the glow plugs but ultimately has lots of information regarding the glow system.




My truck is not nearby ATM, and I can't for the life of me recall the location of the two Glow Plug relays, and unfortunately the parts diagram is not helpful in that regard.
 
Last edited:
Top Bottom