High Oil Pressure?

Joined
Jun 10, 2015
Messages
756
Location
Twin Falls, Idaho
Visit site
Finished my rebuild and now have 100 miles on the rig. Quick question though. My oil pressure hangs out right at the upper range of the gauge. Idle and high RPM’s, hot or cold.

Should I be concerned? What should I be looking for to remedy? Any input is appreciated.
B81A6FC5-35F3-4BB2-B841-1938B743139D.jpeg
 

GA Architect

SILVER Star
Joined
Feb 14, 2014
Messages
3,635
Location
Woodstock, GA
Visit site
Finished my rebuild and now have 100 miles on the rig. Quick question though. My oil pressure hangs out right at the upper range of the gauge. Idle and high RPM’s, hot or cold.

Should I be concerned? What should I be looking for to remedy? Any input is appreciated. View attachment 2719863

Mine rides right at the upper tick mark, and it has been that way going on 7 years and over 30,000 miles.

IMG_8935.jpg


Note: I run Valvoline VR1 20W-50, engine builder's recommendation.
 
Joined
May 3, 2009
Messages
1,011
Visit site
Before having my worn out 2F rebuilt the valve train had enough oil pressure to squirt all over the place if I attempted to adjust the valves with the engine running. Post rebuild not so much. Gauge needle behaves the same as before.
 
Joined
Jun 10, 2017
Messages
295
Location
Washington
Visit site
Get a mechanical gage and install, as @ojaij40 recommended, to see what the actual is, hot engine should not exceed 55 psi at 2400 rpm. The 2F oil pump internal relief is set to that. If the oil pressure needle isn’t moving at all between, hot, cold, idle and rev’s...I’d suspect the sender.

I run a Dakota Digital and it uses a GM sender on an F. If I get moisture or the sender terminals get a bit corroded, pressure indicates high...e.g. bad ground. However, when all connections are tight, the oil pressure is active and moves around under various operating conditions.
 

GA Architect

SILVER Star
Joined
Feb 14, 2014
Messages
3,635
Location
Woodstock, GA
Visit site
Finished my rebuild and now have 100 miles on the rig. Quick question though. My oil pressure hangs out right at the upper range of the gauge. Idle and high RPM’s, hot or cold.

Should I be concerned? What should I be looking for to remedy? Any input is appreciated. View attachment 2719863
Check out post #10 & #17 in this thread -> click here <- = "peace of mind, maybe"
 
Joined
Jun 10, 2015
Messages
756
Location
Twin Falls, Idaho
Visit site
Thanks for all the feedback. The oil pressure is of very minor concern to me and it sounds like as long as it’s not sitting below the normal range, all is well. I may play around with the sender a bit but replace it nonetheless.
 

Users who are viewing this thread

Top Bottom