Problems with Landcruiser 80 on gas

Discussion in '80-Series Tech' started by Kenn13, Sep 21, 2011.

  1. Kenn13

    Kenn13

    Messages:
    10
    Location:
    Belgium
    Hi Guys, My name is Kenneth and I have a Toyota Landcruiser FZJ80 with the 4.5 1FZ-E engine.

    I have a LPI installation in my car and I have some problems with it that they can't solve here, I think I'm the only one in Belgium with this car.

    I have a LPI installation from the brand TARTARINI, does anybody knows that?

    Who's driving here on gas, and what do you think of your vehicule? On gas I lose lots off power.

    Thanx :cheers:
  2. cody c

    cody c SILVER Star

    Messages:
    4,650
    Location:
    calgary
    There have been a couple posts on here about propane as we know it in NA, please try searching first for more info.

    There is a search button at the top of the forum.
  3. Thomo

    Thomo

    Messages:
    79
    Location:
    London, UK.
    I'm running a BRC multipoint system. I can't tell the difference between LPG and petrol.

    Did you have the system installed or was it already on when you bought the vehicle?

    Is your setup a Multipoint or single point system?

    Does it have an ECU?

    Some good info here too:
    DIY LPG

    You can alos contact the website author to ask questions. I quizzed him about a dual tank setup and got reply's from him the same day.
  4. Kenn13

    Kenn13

    Messages:
    10
    Location:
    Belgium
    It's a multipoint system with 6 injectors. It has been installed by an official installer. They don't know the car here in belgium so they have lot's of problems with it. I still have garantee on the car but they say that everything is working perfect, it's something with the car itself and not with the gas.

    I like driving in it so I hope I can fix it otherwise I have to sell it and buy a stupid diesel :(
  5. Thomo

    Thomo

    Messages:
    79
    Location:
    London, UK.
    If it runs fine on petrol then there isn't anything wrong with the car. It will have to be the LPG setup that is causing the problem. Them not knowing the car shouldn't be an issue...

    How have they proved to you that everything is working fine?
  6. rove_mcanus

    rove_mcanus

    Messages:
    766
    Location:
    Somewhere down under
    You do lose some power running on gas as it is not as efficient as petrol.

    First I would check the spark plug gap. as a general rule it should be 0.1mm smaller than the petrol specification
    Then advance the timing. LPG needs more advance at lower rpm.

    Then remember that these settings won't work well with petrol. You can only ever tune it to run properly on petrol OR gas, not both.
  7. hybric4x4diesel

    hybric4x4diesel

    Messages:
    231
    hi there, ingition timing & compression ratio, play a very importance rule in power & fuel effici.. .patrol flame speed start fast & ended slow in speed per second (2.72 vs 2.69) lpg -start slow but ended fast in flame speed. so higher timing at idle & less total timing advance at higher rpm.e.g i would run 10deg -15deg at idle & 32deg-36deg at full advance,much less compare to patrol. try these & see what happen. for compression ratio lpg runs best with 10.5 -1 ratio.
    over here we in canada & america have better power over gas engine only when these two issues have been alter , compression ratio & ingition timing.
  8. Kenn13

    Kenn13

    Messages:
    10
    Location:
    Belgium
    everything is new, new spark plug , new cables, everything... he did run fine with the original spark plug gaps but 2 months later I have lots of problem and they don't know what it is.
  9. Kenn13

    Kenn13

    Messages:
    10
    Location:
    Belgium
    [​IMG]

    [​IMG]

    [​IMG]
  10. freshspecbluegt

    freshspecbluegt

    Messages:
    309
    Location:
    Carlsbad, CA
    Half the forum here would kill for a diesel 80, it never sold as an official model here in the US.
  11. Kenn13

    Kenn13

    Messages:
    10
    Location:
    Belgium
    In Belgium they only sold the HDJ80. I have the only FZJ80 that I know. Original lockers and VX version.

Share This Page