Surging at mid throttle

Joined
Apr 5, 2019
Messages
5
Location
Purcellville, va
New member, but have used Ih8mud forums extensively for trouble shooting/upgrades, thank you. I now have an issue I have not found a posting for. I have a 3B Diesel and recently installed one of Keith’s turbo kits (can’t recommend this enough, like a different engine altogether), idles perfecty, acceleration is better than ever, but at mid-throttle surges and bucks. Stops as soon as I accelerate or decelerate, but at consistent speed, in any gear, at any speed, it bucks/surges/pulses violently. I’ve bled and rebled fuel system, changed fuel filter, checked clamps on both hoses going TB, and clamps on fuel return line. Problem seemed to start after replacing fuel return line (cracked during engine install), could that possibly have anything to do with it? I pulled the hose and at idle fuel drips from the return so seems to be working. IP Diaphragm seems fine, tons of power, no problems under acceleration. Checked fuel cutoff adjustment, no problems there. Has anyone seen this before?
 
Joined
Mar 4, 2012
Messages
774
Location
Adelaide, South Australia
Also.. its not done very often but I've seen some 2H turbo installations done with the throttle body butterfly relocated to the turbo outlet.. I questioned this a while back and apparently it stopped "surging" but I never got to the bottom of it. Have you had this engine running well at all since the turbo went on?
 
Joined
Apr 5, 2019
Messages
5
Location
Purcellville, va
duncanm, thank you. I did not replace the crush washers, but nothing leaking. The outlet for the return line I bought to replace my damaged line is on the opposite end of the engine, the new one I purchased has the outlet nipple toward the front of the engine, my damaged one was at the rear, any chance that matters? The TB is on the intake manifold and turbo outlet attaches to the TB, not understanding where the butterfly could be relocated.
 
Joined
Mar 4, 2012
Messages
774
Location
Adelaide, South Australia
The outlet point should not affect the return line. I would source the correct crush washers and reinstall for completeness, they are not reusable.

Also.. has this engine actually run well since the turbo went on?
 

roscoFJ73

 
 
Joined
Jul 22, 2003
Messages
16,973
Location
Perth Western Australia
I would try a separate fuel supply. You may have a blocked fuel pick up, they sometimes cause weird fuel starvation at various rpms and go away at lower or higher rpms
 
Joined
Apr 5, 2019
Messages
5
Location
Purcellville, va
Solved it! I connected the Venturi to the throttle with a rigid linkage, which caused the Venturi to open and close with every bump due to the movement of the engine, the first bump caused it to pulse and the pulse would build as the engine surged. I replaced the linkage with a cable, fixed. Thank you for your help.
 
Top Bottom