Stock 1hdtft upgrade to Gturbo Badboy or Grunter ? (2 Viewers)

Joined
Aug 8, 2016
Messages
15
Location
Western Australia
Hi all I'm new to this so please excuse me if this the wrong forum,

I've got a stock 1hdft 80 series manual with 380,000km on it in great condition over serviced if anything.
It's our family car shopping trolley and touring set up, I've had it for 15 years brought my children home from hospital ect. Ect. So to say it's a part of the family is an understatement.

It's getting long in the tooth and other diesel cruisers are getting more refined but I Just can't part with it, so it's time to start "upgrading a stock 1hdft" I'm apprehensive, so to try and do things right I've just ordered a HPD front mount intercooler, catch can and a moonlight industries air box, (already has a3" exh) with the intent of upgrading to a Gturbo now to just decide which one a Badboy or Grunter ?

We go on remote holidays towing an off road trailer so reliability is at the top of my list.
Concerns are excessive blowby & decreased engine life, I've read a heap of threads here and all have had different experiences but all seem to be recent with no long term kms under the tyres, so any real world experiences would be great to hear. Sorry for the babble just wanted to try and paint a picture.
 

Tapage

Club 4X4 Panamá
SILVER Star
Joined
Apr 4, 2003
Messages
23,549
Location
Panamá
 
 
 
I'm not sure how translate the model I have .. but it's of the first ones .. and it's sill doing it indeed purpose years later with my 315 / H150 / 1HD-T
 

Locked79

SILVER Star
Joined
Aug 14, 2012
Messages
967
Location
Ayr, QLD
 
+1. Got my first turbo off Graeme in 2012 and it's still going strong to this day. 32psi for 4 years out of an early version, outstanding reliability and I really can't fault it. And I'm a fussy ****.
 
Joined
Aug 8, 2016
Messages
15
Location
Western Australia
image.jpeg
image.jpeg
Too far in now to turn back ... Progress is good Grunter fitted (I didn't take the exh manifold off but next time I will) the heater hose steel pipe that runs behind the turbo turned at the union where it comes out the front of the block, I don't know what sort of joint it is hoping it's an oring ? and won't leak ... pressure tester has been on it for about an hour nothing yet fingers crossed, HPD front mount almost plumbed up its really tight fit but there isn't any other way the pipes could be run unless going under the guard is an option your happy with... Bending the aircon pipe to cut the hole in the LHS rad support goes against anything I've ever been taught but so far so good.
 

Tapage

Club 4X4 Panamá
SILVER Star
Joined
Apr 4, 2003
Messages
23,549
Location
Panamá
 
 
 
It was way more easy to me pull the hole thing ( turbo and manifold ) than just the turbo ..
 
Joined
Aug 8, 2016
Messages
15
Location
Western Australia
Yep lesson learnt tried to take a shortcut and as usual not so short , the dyno day has to be brought forward a week so I'm now rushing I was only notified yesterday so I didn't want to temp fait with broken manifold studs and no time to fix them.
 
Joined
May 2, 2011
Messages
2,996
Location
Paradise
 
Nice work If you ever have problems with the intercooler it looks like a easy job to take it out of the system. :)
 
Joined
Aug 8, 2016
Messages
15
Location
Western Australia
No smoke out of it yet just tiding everything up, I have brought a hpd catch can but it isn't a"bolt up kit" (for mine anyway) might have something to do with the abs as they bolt up to the brake master cylinder and mines got a plate already there ? bit disapointed I'll have to sort later no time for it and it'll run without it.


Nice work If you ever have problems with the intercooler it looks like a easy job to take it out of the system.
Yeah it's not a bad kit the turbo outlet pipe seems small but I'm sure HPD do a lot of R&D it's their main business. Cheers.
 

IanB

SILVER Star
Joined
Jan 23, 2010
Messages
4,355
Location
Winnipeg, MB
 
 
No smoke out of it yet just tiding everything up, I have brought a hpd catch can but it isn't a"bolt up kit" (for mine anyway) might have something to do with the abs as they bolt up to the brake master cylinder and mines got a plate already there ? bit disapointed I'll have to sort later no time for it and it'll run without it.
Probably because you're manual trans and have the clutch master cylinder on the firewall where it would go, but that sucks all the same. There's also a couple different bracket options based on the brake master cylinder your truck is equipped with (2 bolt vs. 4 bolt) if memory serves me.
 
Joined
Aug 8, 2016
Messages
15
Location
Western Australia
Well been down on the Gturbo dyno 142kw @ all 4 on 285/75/16s torque was 460nm, very happy with low down response it's a huge improvement over standard, fuel usage with no camper but roof rack 14lt/100 camper trailer on 17lts/100 happy with that. Max boost is only 18 psi @ inlet manifold thought that would have been a little higher but its never up there only when I really push it. Response is so good I now have to watch it if I need to take off at a corner quick the inside wheel spins !
Down side, it now lets out a big puff of black smoke @ startup due to the max fuel screw being wound out this sort of sucks in a car park, a lot more smoke when engine is lugged , between gear changes it puffs, but I'm guessing no power without fuel.
Towed the camper @ about 125 km/hr (I know limit is 100) and the egt after turbo went to 700'c !!! Engine temp went up to 3/4 it has never been there before and has towed at that speed before, so either the HPD front mount isn't letting much air into the radiator or there's to much fuel at the top end and the cooling system can't cope ? I'm guessing fuel as it's done it before no dramas and the FMIC is fairly big. As soon as I back off to cruising speed of 100km/hr the egts go back to 300-350c I'll give Gturbo a call and get their thoughts.
All up happy with the way things turned out and I'm sure with a bit of tweaking it can be sorted.
 
Joined
Aug 8, 2016
Messages
15
Location
Western Australia
Mine fits with a clutch master
I called HPD they said ABS is uncommon and they understood it wouldn't fit (I have 2x 95 80 series and both have ABS) they said send a photo and they would help, well I did and followed up to see if they got it but to this day no response, so I made my own bracket coming off the factory cruise and a/filter mounts then ran the outlet pipe into the front chassis rail it's a better outcome just disappointing no one followed it up poor customer service. So if you've got ABS buy the universal one and some steel.
 
Joined
Jun 10, 2007
Messages
5,418
Location
Kiwiland
 
 
Towed the camper @ about 125 km/hr (I know limit is 100) and the egt after turbo went to 700'c !!! Engine temp went up to 3/4 it has never been there before and has towed at that speed before, so either the HPD front mount isn't letting much air into the radiator or there's to much fuel at the top end and the cooling system can't cope ? I'm guessing fuel as it's done it before no dramas and the FMIC is fairly big. As soon as I back off to cruising speed of 100km/hr the egts go back to 300-350c I'll give Gturbo a call and get their thoughts.
All up happy with the way things turned out and I'm sure with a bit of tweaking it can be sorted.
Post turbo EGT is useless, you need it pre-turbo. 700C post turbo could be over 900C in the manifold!
You also need more boost. 18psi ain't enough if your EGT is getting that high.

More boost means more airflow and better cooling.
 
Joined
Jun 30, 2013
Messages
147
Well been down on the Gturbo dyno 142kw @ all 4 on 285/75/16s torque was 460nm, very happy with low down response it's a huge improvement over standard, fuel usage with no camper but roof rack 14lt/100 camper trailer on 17lts/100 happy with that. Max boost is only 18 psi @ inlet manifold thought that would have been a little higher but its never up there only when I really push it. Response is so good I now have to watch it if I need to take off at a corner quick the inside wheel spins !
Down side, it now lets out a big puff of black smoke @ startup due to the max fuel screw being wound out this sort of sucks in a car park, a lot more smoke when engine is lugged , between gear changes it puffs, but I'm guessing no power without fuel.
Towed the camper @ about 125 km/hr (I know limit is 100) and the egt after turbo went to 700'c !!! Engine temp went up to 3/4 it has never been there before and has towed at that speed before, so either the HPD front mount isn't letting much air into the radiator or there's to much fuel at the top end and the cooling system can't cope ? I'm guessing fuel as it's done it before no dramas and the FMIC is fairly big. As soon as I back off to cruising speed of 100km/hr the egts go back to 300-350c I'll give Gturbo a call and get their thoughts.
All up happy with the way things turned out and I'm sure with a bit of tweaking it can be sorted.
Hi,

I know this is an old post but interested how EGT and coolant temp issue was resolved - def not what you would expect from what GTurbo advertises. Sounds like way too much fuel?
 
Joined
Aug 8, 2016
Messages
15
Location
Western Australia
Not sorted yet I’m 450kms from the nearest dyno so haven’t been back, I called Gturbo and they advised to check pump timing I’ve done this it’s set to 1.43mm wich is max factory advance, I’m going to get back there mid this year as I’m off to the canning stock route later on and want it right. As far as performance goes I haven’t had any trouble and know it’s limits, mate of mine has a chipped auto 2014 ranger and it is only marginally quicker so still very happy with the improvement just needs refining.
 
Joined
Jun 30, 2013
Messages
147
Interesting. Did it not present the same issues on their dyno when they tuned it?

I would have thought you could beat 14l/100 on an intercooled FT at highway cruise.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 2)

Top Bottom