slight whine when turning (power steering)

Joined
Nov 1, 2018
Messages
20
Location
Nashville TN
2006 Land Cruiser 110K miles

I had my timing belt / water pump / serp belt / tensioners , seals, etc. done today. I drain and filled my power steering fluid on October 31st. I noticed when pulling into a parking deck earlier that when I turned my vehicle there was a faint whine noise. It is only when I turned and is intermittent. What could this mean? My first thought was the shop that did my belts and water pump must have knocked something on my power steering system. Then I started thinking about whether there is either a little air in my system or not enough fluid. When the vehicle is completely straight the fluid level is directly between Min and Max on the resevoir.

Anyone got an idea of what this could be?
 
Joined
Jun 23, 2016
Messages
2,546
Location
Wyoming MI
Are there air bubbles in the fluid? Does it look foamy?
Did you use ATF and not power steering fluid?
I like to keep mine right at the MAX line.
 
Joined
Nov 1, 2018
Messages
20
Location
Nashville TN
Are there air bubbles in the fluid? Does it look foamy?
Did you use ATF and not power steering fluid?
I like to keep mine right at the MAX line.
Used to have an 04 cruiser. Miss it.

I used Dexron II or III ATF fluid. After we drain and filled twice I turned the wheel (front end was lifted the whole time) back and forth at about 50% until my buddy said there was no more bubbling. Could be that i need to do that again? I dont think it looks foamy but ill have to go check it out.
 
Joined
Jun 23, 2016
Messages
2,546
Location
Wyoming MI
I always turn the wheel lock to lock when doing a flush.
The air should work itself out with you driving.
If it were me I'd fill to the max mark and drive it making sure I went to lock to lock a few times making u-turns, don't hold it at full lock, just until you hit the max travel for the wheel, then hold for 5sec or so and release.
Then do the other side.
That should do the trick.
It sounds to me either like air in the system or the power steering pump bearings are not getting oil for some reason.
But my money is on air in the system.
 
Top Bottom