RTH (1 Viewer)

Joined
Sep 29, 2009
Messages
1,481
Location
PHX AZ
Stuck at car wash and truck wont turn over. All lights work and electrical. Doesnt make any noise except for a click when i turn key.
 
Joined
Sep 29, 2009
Messages
1,481
Location
PHX AZ
Got it started finally.

Something got wet and it caused it to not start.

After we pushed it to a sunny spot and left the hood up and gave it 10 min she fired right up.

Any thoughts about what got wet?
 
Joined
Apr 9, 2003
Messages
1,512
Location
Ahwatukee, Phoenix, AZ, USA
Check your battery terminals. Check wiring to starter. Check fuses. What kind of battery and how old?
Sounds like a battery issue to me.

Sent from my SGH-T959 using IH8MUD
 
Joined
Sep 29, 2009
Messages
1,481
Location
PHX AZ
Battery is three years old.

It has new battery terminals on it and they where tight.

Long story short I believe it to be the starter since I have been having a few issues with it not sound right. I am going to put my old starter in with new plunger and contacts Sunday. I am interested in knowing how to check the wire going to the starter since In will be working on it. My train of thought is if I have the same issue with the noise from my old starter as well then I have a wiring problem. The only way I can explain the sound is that it sounds like the starter is bogging down or literally catching on something. Murf had his techs check my flex plate when the transmission was off to do the rear main oil seal and they said it was in good shape.

Really though, it seemed like something dried out and then it stared working again. Is there anything at the back or front of the engine that if it got wet could short causing the truck not to start?
 
Joined
May 31, 2003
Messages
8,473
Have you thought about selling her lately? If you did, then you need to talk to her, tell her you are not going to sell her. BTW, I learned this from a CSC member, and it worked for him :cheers:.
 

Users who are viewing this thread

Top Bottom