Passenger Side Mirror does not go up or down using the switch (1 Viewer)

Joined
Sep 7, 2016
Messages
17
Location
Massachusetts
06 LX470

Ok so I've dug out all kinds of threads about power mirror issues, but cannot see any real resolution for my case below. Any ideas help would be great, please.

Problem:
Passenger Side Mirror does not adjust Up or Down
Left to Right motion works
It does go down and then back up during backing up the car - So this means that the motor works, unless I do not know something. Also is it safe to say that EWC works fine on that side?

Mirror switch was removed and cleaned, which I thought should not help anyway, because it's the same buttons that control driver side mirror (looking at the contacts in the switch lead me to that conclusion)

I cannot hear any sound in the mirror when clicking on the up or down on the switch.
Is there a fuse for just up and down motion?
Thank you in advance all.
 
Joined
Sep 7, 2016
Messages
17
Location
Massachusetts
I think I've isolated the issue to the switch, after using test function in TechStream!
You can press the switch's buttons UP/Down Left/Right in Driver or Passenger selected function and see the Voltage change and sure enough nothing happens in my case during UP/Down for Passenger mirror. Also you can test from Tech stream other test to see if the mirrors all motions work properly.
Hope this will help someone.
 
Joined
Sep 12, 2016
Messages
307
Location
Riverside, CA
Mine does the same thing. I thought it might be the motor for the mirror. I'll definitely check the switch now.
 
Joined
Sep 7, 2016
Messages
17
Location
Massachusetts
I think I've isolated the issue to the switch, after using test function in TechStream!
You can press the switch's buttons UP/Down Left/Right in Driver or Passenger selected function and see the Voltage change and sure enough nothing happens in my case during UP/Down for Passenger mirror. Also you can test from Tech stream other test to see if the mirrors all motions work properly.
Hope this will help someone.
As I've mentioned in the above finds about the mirror - I WAS WRONG :-( Still do not know what is it. Next thing I am suspicious about the wires that I've unplugged from AHC computer when I did the AHC delete, in order to eliminate the flashing orange on the dash. There were 3 plugs, need to trace things around I guess.
 
Joined
Feb 23, 2007
Messages
36
 
I have exactly the same issue. One mirror does not respond to the up \ down button but the other one does. The mirror that does not respond to the button does however move down when selecting reverse and back up again when coming out of reverse. To my mind, the fact the up \ down buttons work with one mirror means the buttons are OK, the fact left \ right works with both mirrors means the left \ right selector switch is OK and the fact the mirror moves when selecting reverse means the mirror motors are OK. What else is there?
 
Joined
Aug 5, 2005
Messages
458
Location
Ontario, Canada
 
 
 
[Edit: never mind, I see you cleaned the contacts already....]
The switch in our LS looks the same and the contacts oxidized over time. I removed the switch, carefully pried it open and cleaned the contacts with electrical contact cleaner. Solved the problem. Here is some info: Mirrors no longer adjujst - ClubLexus - Lexus Forum Discussion. 7 years later, it looks like it needs to be done again. Worth a try.
 
Joined
Sep 7, 2016
Messages
17
Location
Massachusetts
Joined
Dec 30, 2019
Messages
5
Location
san diego
Any further progress on this? Just got a 2005 LX and it’s giving the exact problem described above. The door switch relay clicks from all inputs. I tore it apart and regreased as much as I could. They both fold in just fine. No up/down on passenger side.
Any other thoughts would appreciated.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom