Newly acquired LX470 - front door speakers don't work at all

Joined
Apr 18, 2017
Messages
41
Location
Mississippi
I have ML audio. I've seen threads where the whole left/whole right has gone out indicating amp problems. I haven't seen anything where only the front 2 door speakers give out.

Has anyone else has the issue of both front door speakers not making any noise? Trying to get a feel for it before I take both door panels off.

I have a sneaking suspicion that previous owner might have unhooked both of them because they were self-destructed like so many other people's on the forums. I am going to have to get to them at some point and may try to repair them if that's the only issue.

While we're here:

I've read up on the options for replacing speakers and it seems pretty depressing - has anything happened recently that gives more options for replacing the speakers?
 

labcab

 
Joined
Jun 21, 2005
Messages
588
Location
Apex, NC
The fronts and rears are interchangeable. Plugging the rear speaker into the front's harness would be a quick test to see if the wiring is intact, or other work is necessary.
 
Joined
Apr 18, 2017
Messages
41
Location
Mississippi
Unfortunately, all of the offerings on Crutchfield will not work on the LX470 with ML system. All of the speakers listed are 4 Ohm and the ML system needs an 8 Ohm speaker.
 

PADDO

SILVER Star
 
Joined
Sep 27, 2007
Messages
1,743
Location
Charlotte NC or ACT area Australia
Unfortunately, all of the offerings on Crutchfield will not work on the LX470 with ML system. All of the speakers listed are 4 Ohm and the ML system needs an 8 Ohm speaker.
Impedance matching is all about maximum power transfer - speakers with impedances other than OE work just fine from my (and lots of others) experience.
 
Joined
Jan 22, 2017
Messages
27
Location
Odessa,FL
I have done absolutely no searching on this but....typically car audio is at 4ohms while home audio is 8ohms. My suggestion would be to search for "home" audio speakers and that should net you with 8ohm speakers.

Another option would be to wire (2) 4ohm speakers in series at the amp to get an 8ohm load. (you will lose "front / back" or "left / right" as they would be "wired" into 1 if that makes sense)

Or you could just see if the amp can handle 4ohm load which is possible. Just because ML used 8ohm speakers may not mean the amp cannot handle a 4ohm load.

Again, I have not done ANY research into the ML system ( i do need to because my 04 doesn't sound nearly as good as I've heard the ML system to be).
 
Joined
Apr 18, 2017
Messages
41
Location
Mississippi
Impedance matching is all about maximum power transfer - speakers with impedances other than OE work just fine from my (and lots of others) experience.
How long have you had 4 Ohm speakers installed?

I may try to repair the originals. Everyone says that even after repair they still aren't high quality though. Not really that encouraging.
 

PADDO

SILVER Star
 
Joined
Sep 27, 2007
Messages
1,743
Location
Charlotte NC or ACT area Australia
How long have you had 4 Ohm speakers installed?

I may try to repair the originals. Everyone says that even after repair they still aren't high quality though. Not really that encouraging.
Changed out my door speakers (left front mids alone) about 18 months ago. Not sure what MY LX you have but on the 03s ML 11 speaker system I don't believe the OEs are 8 ohm, more like 6 ohm iirc. I'll check the dc resistance of my takeoffs later and the specs for the replacements. Possible the sub is 8 ohm, but mine wasn't blown so I didn't touch it or bother to check its dc resistance.
 
Joined
Apr 18, 2017
Messages
41
Location
Mississippi
Mine is an 03 too. I may replace the speakers with some off crutchfield - did the crutchfield supplied adapter work for you or did you use a different one?
 
Top Bottom