New to me LX470

Joined
Sep 1, 2018
Messages
183
Location
Florida
Hello all!

New member. Been looking to get a family expedition vehicle for a while since we traded in my xterra three years ago and just purchased a 2006 Lx470 in West Palm Beach, FL last weekend.

I'm slowly working my way through the issues (no matter how pretty they look, there's always something to fix!). So far I've gotten a new exhaust, I'm literally writing this post in the tire shop getting 33's installed (and found out all five tire sensors are dead) , and my mini vci cable will arrive tomorrow. I really would like to turn off the auto retract steering wheel. Also replaced the non-working auto antenna mast.

There's still a list of things to get through, however:

- only have 1 key
- check engine light for emissions (p0441 and 0455). Hoping a gas cap fixes that
- vsc and trac lights come on occasionally for code c1340... Bought new center diff lock sensor to try and fix. Any other thoughts? Read all the forum posts I could find and none really helped
- ahc fluid reservoir is a bit low
- driveline thunk is coming from the front drive flanges, so have those on order
Edit:
- also saw a b2799 code pop up once. Any thoughts there?

Unfortunately, I've had to spend a fair bit fixing these things so far, but hopefully I've got it all covered now!

On the plus side, everything works and it's only got 135k miles on it. The interior with the exception of the drivers seat is in like new condition. Timing belt and water pump were replaced at 105k as well, so big plus there.

Anyhow... Hello!
Attach9349_20180825_141403.jpg
 
Last edited:

Mauser

Supporting Vendor
Joined
Jun 20, 2018
Messages
870
Location
Central New Mexico
Congrats. Not only do I love driving my LX I also enjoy working on it.

Check to make sure your key is a master and have a couple made, if you lose your only key it can be a mess. If it isnt a master you can fix that when you get your techstream set up.
 
Joined
Jun 28, 2016
Messages
122
Location
Arizona
Welcome! I am going through a similar process with my LX! I picked up a 98 with 158k miles but low miles means it was not driven much and sat around for a while. Below is another thread that has helped me a lot. Hope it'll help you out as well! btw not my thread, just another mudder that took the time to help out!

LX470 Maintenance Schedule
 
Joined
Sep 1, 2018
Messages
183
Location
Florida
Welcome aboard!
Thank you!

Congrats. Not only do I love driving my LX I also enjoy working on it.

Check to make sure your key is a master and have a couple made, if you lose your only key it can be a mess. If it isnt a master you can fix that when you get your techstream set up.
Going to hopefully get a new key cut shortly. Part of the reason I wanted techsteam is for keys and such. I've heard I can get a new key from lexus, but I can't imagine the cost involved!

Congrats, that's a sharp looking truck. Almost looks like a new vehicle.
Thank you! Definitely had been well cared for... Had several folks in my neighborhood think it was new!

Welcome! I am going through a similar process with my LX! I picked up a 98 with 158k miles but low miles means it was not driven much and sat around for a while. Below is another thread that has helped me a lot. Hope it'll help you out as well! btw not my thread, just another mudder that took the time to help out!

LX470 Maintenance Schedule
Definitely appreciate it! I know there are several things I'm going to do just because I want to know they're done... Like the t case and the diffs.
 
Joined
Sep 1, 2018
Messages
183
Location
Florida
Unfortunately, I have a quite short wife and and 1 year old, so running boards have to stay for now. Definitely will come off for any major off road trips we make though, until I can afford some rock rail steps.
 
Joined
Sep 1, 2018
Messages
183
Location
Florida
Been a while - got lots of work done lately!

- New (RockAuto) exhaust installed
- C1340 Light Fixed (link)
- Ordered and had cut Ebay key; clicker works but transponder doesn't, so won't start the LX. Good spare if I lock my keys in the LX at least.
- Bought a spare transponder key; no clicker but it will unlock and start the vehicle.
- New u-joints. What a nightmare - shouldn't have touched them!
- New CV Axles, bearings, drive flanges, and upper ball joint rubbers. Beefiest axles I've ever seen...frickin heavy! (see new vs old comparison below)
- Installed Grom Audio aux line input. Replaced cigarette lighter socket with aux line input; makes for a very clean install. (see below)
- Built and installed a set of shelves in the trunk that lets me store a bunch of crap without piling it up. Makes it a lot easier to get in and out at the campsite.

Next on list is removal of side steps and installation of OEM mud flaps. Hopefully this weekend, but definitely before winter break!
 
Last edited:
Joined
Sep 1, 2018
Messages
183
Location
Florida
Added stuff for single day camping trip to make sure we're prepared for camping with a sixteen month old baby!

 
Joined
Jan 3, 2010
Messages
864
Location
Southern California.
If you’re not reliant on the running boards for entry, take hem off. Big difference in appearance.

View attachment 1779893

View attachment 1779894
Yeah definitely makes a difference in looks, went from a nice looking cruiser to hmmm not so good looking.... In my opinion that only looks right with 33s, roof rack, steel bumpers, without that its incomplete...

but hey thats just me...:flipoff2:


happy holidays ask santa for them 33s:santa:
 
Joined
Sep 1, 2018
Messages
183
Location
Florida
So this happened on my way to work this morning. Guess an alternator replacement is happening this weekend :-(
 
Joined
Sep 1, 2018
Messages
183
Location
Florida
Yeah, I saw that. I've ordered a duralast gold (lifetime replacement variety) alternator for it, but will take apart the one that comes out to see if it just needs a brush kit or something. It's odd - it worked fine last night when I parked it. Haven't had a single charge issue in the few months I've owned it. This morning, zero output from the alternator...no warning, no flickering light, just dead. Seems like the regulator died or something. I think there's a whining noise coming from it too.
 
Top Bottom