New T100 to the Forum, Driving Through Central America (1 Viewer)

Joined
Apr 5, 2017
Messages
28
Location
central america
Hi all.
I have been driving my truck (1995, T100, 4x4) with homemade camper through Mexico and Central America for the past 9 months.
attachment.php

My wife and I started in California and are now in Nicaragua. We plan to make it down to Panama and turn around in a few months. Then We'll be making our way north, back to the USA.
attachment.php

attachment.php


attachment.php


I've been checking out some information here on IH8mud as a recommendation from some folks over on expeditionportal. I like what I see so I decided to join.
 
Joined
Apr 5, 2017
Messages
28
Location
central america
The truck has been doing well. We've had a few minor issues: starter, battery, idler arm, tires, repack a front wheel bearing. Got to expect that though when you buy a truck with nearly 200k miles and leave on a trip like this less than 2 months later. :)
 
Joined
Apr 5, 2017
Messages
28
Location
central america
Wow awesome looking trip! What did you do to the truck to prepare for that trip?
I bought it 2 months before leaving, so I didn't know much about the maintenance history. I changed all the fluids and checked everything I knew how to check. ended up finding that the front shocks were shot and had one torn cv boot so replaced those.
Other than that we built out camper, made a few mods to the interior of the cab, and installed a secondary battery/solar system.

The truck is basically stock and I chose the make/model because vital parts are available throughout Mexico and Central America so I set out assuming that we would have problems at some point (everyone dose) but that we would be able to deal with it on the road.
 

Users who are viewing this thread

Top Bottom