NA 3B EGT Temp Too Low? (1 Viewer)

Joined
Aug 2, 2019
Messages
260
Location
Wilmington, North Carolina
Hey there, I recently installed an EGT gauge all went well... I think, but I think like my temps are too low from everything else I've read online. It stays between 400-600 degrees Fahrenheit at all time pretty much, I was able to hit 700 for a couple of seconds when I ran it really hard from a dead stop. I don't have a tach so I'll just be doing it by speed.
My avg temps are as followed:
Idle - 400f (205c)
60kph - 450f (232c)
90kph - 580f (304c)
100kph - 600f (315c)
From what I've read on the threads from other people they run around 880f-1150f (470-620c) but usually stay around the high 900's (low 500c) at highway speeds from 100-110kph. Here the location of the probe
IMG_5509.jpg

Maybe I just have an extremely cool running 3B, or I need to add more fuel into it, or something was messed up with the install, who knows. If anyone has any info or personal experience with EGT's in general I'll happily hear it! Thanks
(Also I'm aware that EGT's don't really matter on a non-turbo diesel, I was just interested in seeing how much it would change when I do turbo this engine)
 
Joined
Aug 2, 2019
Messages
260
Location
Wilmington, North Carolina
Are you hunting a bit more performance or are you happy with the vehicle?

There's no way I'd want any of my 2Hs anywhere near the 470-620c you've quoted.
Well, it's a NA 3B so anything regarding performance (other than a turbo) is pretty much useless and I've come to accept that haha. I was just wondering if my gauge was off or broken or something along those lines, just from all I've read online it doesn't seem that hard to get high temps, while I could only hit 700f (370c) when it sounded like my engine was about to shoot a piston into outer space. I kinda just put this thread out to see what other people run for usually their EGT's and if my EGT's were any bit comparable to theirs.
 
Joined
Jul 27, 2018
Messages
188
Location
North Carolina
Nevermind lol, just found this great thread EGT Temp Guide, my worries have been dulled. I guess my rig just runs a bit cooler than everyone else's :)
With out having a turbo you shouldn't see those higher EGTs that are in the thread you linked. I think your numbers are "real" and your probe is measuring correctly. Throw a turbo on and see what happens ;)
 

Users who are viewing this thread

Top Bottom