MV50 Fuses Keep Blowing

Joined
Jan 4, 2003
Messages
161
Location
Oxnard, CA
Has anyone else had problems the the MV50 (also called the M1050 I think) air compressor blowing fuses? I've heard of people running them on continuous duty for upwards of 30 mins, but I went through 2 fuses in less than 15 mins last weekend. Both blew after stopping the compressor to switch tires then trying to turn it back on. Is mine just defective? It's only been used to air up 4 tires 4 times :(.
 
Joined
Dec 22, 2003
Messages
514
Location
VA
There was a post within the last year or so with someone that had to replace the relay in one. I don't know if your problem is related to this but maybe this will jog someones memory and can add more.
 

e9999

Gotta get outta here...
Moderator
Joined
Sep 20, 2003
Messages
17,857
Location
US
no problem with mine.

I did see somebody once who used a newish one without having taken the plastic wrapping off the vents, things did get kinda hot apparently.... don't recall anything said about popping the fuse though.
 

619TOY

SILVER Star
Joined
Jun 27, 2006
Messages
2,062
Location
San Diego
A wheeling buddy of mine was using his at Tierra Del Sol a few weeks ago. I happened to glance over at it just in time for smoke to start billowing out of it. The wire had gotten loose just inside the case and was arcing, causing enough heat to melt the cable. You may consider checking this as well. If the power wire intermittently shorted, it would blow fuses.
 

Users who are viewing this thread

Top Bottom