Grom VLine (1 Viewer)

Joined
Jul 25, 2011
Messages
1,282
Location
Raleigh, NC
I just ordered my Grom Vline2 for my 2013. It should be here by end of the week. I will do my best to document the install, setup and tips &tricks in a separate thread. A few things I will be focusing on are:
  • Carista Android OS App functionality/communication with Carista ODB2 Interface
  • Icom RS-MS1I Android OS App functionality for controlling the Icom ID-5100a HAM Radio
  • Apple CarPlay functionality and responsiveness
    • Waze responsiveness
    • Spotify sound quality
  • GaiaGPS CarPlay functionality vs GaiaGPS Android OS App funtionality
  • SwitchPros Android OS App functionality
  • Webex/Zoom Android OS App Functionality
  • Streaming Android OS Apps
    • DirecTV
    • Netflix
    • MLB.tv
  • APRSDroid Android OS App Functionality
  • GoPro Android OS App functionality and connectivity range for cameras mounted on vehicle exterior/roof rack etc.
  • Escort Live Android OS App for Escort 360Max radar detector
If anyone has messed around with any of these on the Grom, let me know so I can eventually pick your brain.
Definitely please share the feedback as I am sure it will help folks make a decision if jump in or not on the group buy. Looking forward to your write up.
 
Joined
Nov 2, 2006
Messages
1,447
Location
Spokane
I deleted references I had regarding the group buy as I don't have the confidence in the product to run it any longer, but it sounds like another member may spearhead it. My biggest concern after my unit would not work, is Grom told me the unit works fine on the bench, and they have no idea why it wouldn't work for me. I haven't seen any additional installs for a 16+, only 15 and older.

I was trying to get them to work with me on a fix, but since they don't know what is wrong, I'm giving up completely on the product.
 
Joined
Mar 10, 2012
Messages
245
Location
Kingwood, TX
Thanks for the effort and the frank feedback. The whole point for me behind the 200 is reliability and a device that doesn't provide that is worthless.
 

TheGrrrrr

GOLD Star
Joined
Apr 3, 2019
Messages
889
Location
Scottsdale, AZ
Thanks for the effort and the frank feedback. The whole point for me behind the 200 is reliability and a device that doesn't provide that is worthless.

Well, let's not frame an incompatibility as a reliability issue. Those are two different animals. If it works perfectly with one model year and not another, that is a compatibility issue not a reliability issue. Our goal should be to determine exactly which years it is compatible with, then determine the level of reliability for those compatible years. This is how people will be able to make informed decisions.
 
Joined
Nov 2, 2006
Messages
1,447
Location
Spokane
Thanks for the effort and the frank feedback. The whole point for me behind the 200 is reliability and a device that doesn't provide that is worthless.


For Pre-2016 rigs it seems to work. Probably not a perfect solution, but it is what is available for pre-16s. I was really hoping it would work for my 2016. And to be honest, it might, but I don't have confidence in a product where the company tell me that it should work and they have no idea what is wrong. Hoping a 16+ user has success.

I double and triple checked the install to make sure it was hooked up right and even got the "Grom" startup screen. But then I'd get a black screen with random white lines no matter what I did (followed Grom's instructions to unplug, reboot, etc. Messed with it for a couple hours before uninstalling everything. I even took the time to document the entire process, hoping it would help others, but

At this point, I'll have to be content with my vent mounted magnetic/wireless qi charger.
 

TheGrrrrr

GOLD Star
Joined
Apr 3, 2019
Messages
889
Location
Scottsdale, AZ
USPS Tracking says mine will be here tomorrow evening so I hope to have it installed over the weekend in my 2013 LC. I doubt I'll document much of the install, but I will document any troubleshooting involved in getting it to function correctly. Then I'll start testing apps.
 
Joined
Feb 14, 2017
Messages
303
Location
Norcal
Contacted Grom to see if they fully qualified the Grom VL2 for the 2008 land cruiser. Here's what they said
"Our LEX5 units should work fine but we are still getting some small issues there. Should be clear in couple of weeks if we have a full compatibility or not."
Can't wait for em to qualify it. I really want Apple CarPlay on my LC.
 
Joined
Sep 19, 2010
Messages
2,907
Location
Lost in the Sierras
@40Man What model number of the Grom unit was purchased and returned?

I have one to install tomorrow in my 2017... this is the model they sold me:

Select Lexus 2013-2017 Touch GROM VLine VL2 Infotainment System Upgrade Video Interface CarPlay Android Auto
Item# LEX7TVL2 car make: Land Cruiser 2017
 
Joined
Nov 2, 2006
Messages
1,447
Location
Spokane
@40Man What model number of the Grom unit was purchased and returned?

I have one to install tomorrow in my 2017... this is the model they sold me:

Select Lexus 2013-2017 Touch GROM VLine VL2 Infotainment System Upgrade Video Interface CarPlay Android Auto
Item# LEX7TVL2 car make: Land Cruiser 2017

That is the model that would not work for me. It hooks up just fine, and I even got the Grom screen to work, but then just a black screen with lines after I hit the confirm button on the first screen. Hopefully it will work for you!
 
Joined
Sep 19, 2010
Messages
2,907
Location
Lost in the Sierras
That is the model that would not work for me. It hooks up just fine, and I even got the Grom screen to work, but then just a black screen with lines after I hit the confirm button on the first screen. Hopefully it will work for you!

I will advise on results.
 
Joined
Sep 19, 2010
Messages
2,907
Location
Lost in the Sierras
Getting back to this...

Big delay on the install but got to it yesterday. Looks like same issue as @40Man The issue is as soon as you touch the screen it goes black. I plugged in iphone and booted system and car play came right up on screen... Touched the screen and boom - blackness.

Im engaged with tech support now but so far they have only asked basic questions that could have been handled in 1 email not 7.
 
Joined
Nov 2, 2006
Messages
1,447
Location
Spokane
Getting back to this...

Big delay on the install but got to it yesterday. Looks like same issue as @40Man The issue is as soon as you touch the screen it goes black. I plugged in iphone and booted system and car play came right up on screen... Touched the screen and boom - blackness.

Im engaged with tech support now but so far they have only asked basic questions that could have been handled in 1 email not 7.

Well, that sucks, but at least you have confirmed it is a consistent issue. Too bad...
 
Joined
Jun 7, 2019
Messages
796
Location
Odessa (Tampa), FL
Getting back to this...

Big delay on the install but got to it yesterday. Looks like same issue as @40Man The issue is as soon as you touch the screen it goes black. I plugged in iphone and booted system and car play came right up on screen... Touched the screen and boom - blackness.

Im engaged with tech support now but so far they have only asked basic questions that could have been handled in 1 email not 7.
Maybe you can send them a video of the issue (if you haven’t already). I always forget about this option when dealing with tech support/ customer service departments.
 
Joined
Nov 2, 2006
Messages
1,447
Location
Spokane
Maybe you can send them a video of the issue (if you haven’t already). I always forget about this option when dealing with tech support/ customer service departments.

I sent them video and screenshot. The response after I returned it is it works fine on their bench and they don't know why it wouldn't work. Not very confidence inspiring.
 
Joined
Sep 19, 2010
Messages
2,907
Location
Lost in the Sierras
I provided the pics and video assets. I provided date of vehicle manufacture and the decal information on the back of the touch screen.

I bought this 1/28 and just got to it yesterday. I'm expecting to return it if they dont have a quick solution.
 

Users who are viewing this thread

Top Bottom