Chinese knock off carb question

Joined
Mar 20, 2020
Messages
135
Location
BALLSTON LAkE, NY
Visit site
Good evening, looking for some advice on a Chinese knock off carburetor (Amazon special).
Here are the details:
- 74 F.5 engine came with a Weber carb
- removed Weber and installed Chinese knock off
- carb has been used for 6+ months with no issues, been on the road for the last month and about 400 road miles on it.
- changed out the fuel pump last week, first trip after was great, truck ran well.
- On the way home , I was on the exit ramp and let off of the gas and it seemed off. Pulled in to get gas and it wouldn’t idle. Got home and checked timing, idle adjustments, typical vacuum leaks, idle solenoid. Just couldn’t get it to idle, parked it for the night.
- fired right up the next day and idled like nothing was wrong.
- fired it up today and it was back to the iradict idle again. One minute it’s fine and the next it wouldn't run. Check for vacuum leaks, checked the idle solenoid. Nothing seemed to make sense why one min it was fine and the next a drop in vacuum and rough to almost no idle at all.
- pulled the horn, revved up to 2k and then put a gloved hand over the carb several times. Didnt seem to shake any thing loose, still idled fine for several minutes and then it wouldnt. Fuel in the sight glass was consistent so i dont believe the pump is the issue. I checked and the nozzle seemed to spray fine too.
- pulled the carb, checked the intake (no visible cracks), checked all hose connections, re-torqued the manifold nuts (a couple got a 1/4 turn before clicking). Disassembled the carb, pulled the jets, sprayed in the oraffices, and the jets too. I did have one small spec boil out of the main jet.
- wondering if there is something else I need to check before I reassemble. The carb seems a good copy of the OE and I used the schematic to disassemble-reassemble.

Thanks for any and all assistance and advice.

3A9754FD-4EB3-4C3F-AE6E-3FE9431BF5F8.jpeg


30850ED4-A0F6-4249-B4F4-5BEFD649049F.jpeg


4778A5F3-1302-47FB-BE85-8AED48AA513C.jpeg


A32F02EE-F50C-40BD-B258-4B97CB6B9F8B.jpeg
 
Last edited:
Joined
Mar 20, 2020
Messages
135
Location
BALLSTON LAkE, NY
Visit site
Thanks Matt, kinda had a hunch but wasnt sure how to diagnose. When I cut the power it cuts out like it should. Reconnect and seems fine. Do they work intermittently?
Would a stock solenoid work as a replacement, or do i need to pull it and clean a contact or something?
 
Joined
Mar 20, 2020
Messages
135
Location
BALLSTON LAkE, NY
Visit site
so I went back through the carb, removed the solenoid, blew out all ports i could find and then reassembled. I did find some fine filings once everything was back together, not sure what port they came out of. Reinstalled and started the truck, seems to be back to normal. So my guess is I either knocked something loose in the carb after several months of the new fuel pump had some fine filings that clogged up the idle circuit. Raining so it will be several days before i can road test.
 

ToyotaMatt

Factory Focus-Point Mind-Set Approach
Supporting Vendor
GOLD Star
Joined
Aug 12, 2007
Messages
16,131
Location
EAST COAST
Website
vintageteqparts.com
so I went back through the carb, removed the solenoid, blew out all ports i could find and then reassembled. I did find some fine filings once everything was back together, not sure what port they came out of. Reinstalled and started the truck, seems to be back to normal. So my guess is I either knocked something loose in the carb after several months of the new fuel pump had some fine filings that clogged up the idle circuit. Raining so it will be several days before i can road test.


i would install a NEW FJ60 THICK media type fuel filter on your system before you drive it or start the engine again ..........


HERE is what you need :

DO not install any other filter this BLOCKS ALL foreign matter 99.9% SOLID results ...






1626663967687.png





1626663980592.png
 
Joined
Mar 20, 2020
Messages
135
Location
BALLSTON LAkE, NY
Visit site
thanks, will need to check it out. Still wondering if the new fuel pump contributed to the metal pieces i found after flushing out the carb, or maybe it was in there all along and finally dislodged.
thanks again!
 
Joined
Mar 20, 2020
Messages
135
Location
BALLSTON LAkE, NY
Visit site
Good to know, after I cleaned it i only started it up to get it to temp. I will look in to it, I’m sure Matt was spot on with his recommendation. Drove me nuts as everything is new or rebuilt. And the hit end miss when it acted up made me question the solenoid.
Any one in particular on Amazon to buy from?
 
Joined
Mar 20, 2020
Messages
135
Location
BALLSTON LAkE, NY
Visit site
just wanted to add to those who buy a Chinese knock off carb, disassemble and clean out the ports before putting in to service. I read about it, I rolled the dice and lost. The good news is after cleaning out the filings it is running normal again.
 
Last edited:

Users who are viewing this thread

Top Bottom