Anyone have an alternative for a Cold Start Injector, EDIT: Bad AAV (1 Viewer)

IslandJ

SILVER Star
Joined
Aug 18, 2014
Messages
1,052
Location
Los Angeles
Seeing if anyone has an alternative, and available, part number for Toyota 23260-39056.
Cold start injector for a 1985 22re.
I can find them used but NOS would be amazing. I'd even take some off brand to try.
 
Joined
Jul 31, 2007
Messages
493
Location
San Diego North
sounds like you are in the 22re rabbit hole. I have replaced cold start injectors before, but they never ended up fixing the problem I was chasing. what are your symptoms?
 

IslandJ

SILVER Star
Joined
Aug 18, 2014
Messages
1,052
Location
Los Angeles
sounds like you are in the 22re rabbit hole. I have replaced cold start injectors before, but they never ended up fixing the problem I was chasing. what are your symptoms?
Yes sir. I'll try to make it a "short story". When I first picked up the 4runner almost 2 years ago, it had a very hard time starting cold and had an idle that seemed to vary with a very subtle hesitation in 1st, 2nd and 3rd... I may just not notice it in 4th and 5th.

I have hot bathed the air plenum, rebuilt the fuel injectors(OG's barely functioned), cleaned the Idle air control valve, replaced the screw with an LCE, all new gaskets where they applied, radiator rebuilt, all new hoses and the engine was actually just rebuilt, only 300 miles so far. It runs great besides this slight hesitation and I can feel a slight irregular "poof" that seems to correlate with a subtle stumble at idle.

Spark plugs, cap/rotor, and wires enroute and will switch those out this weekend. I wasnt going to switch those out with the rebuild only because they all weren't that old but I did notice a crack on the cap yesterday so thought I would refresh those items just to be sure.

I read a couple threads that the O2 sensor on the exhaust could cause an issue.

My buddy has a 22re and Ill try his cold start injector before I try another.

Might need to take the IAC valve apart again to check it out. Maybe theres an obstruction in there...
I also just watched this video on a later model IAC valve replacement. He talks about a "ball of wax" that expands in the spring valve.
Maybe the wax has seen its day on the IAC valve for my generation??? The part is NLA Maybe this thread will need a title change, HA
 

pappy

photosynthesizing
Moderator
Joined
Oct 7, 2003
Messages
11,298
Location
Too far north. Too far east.
A few things. If you have a 1985 22RE you have an auxiliary air valve, not an idle control valve. Ya, it does the same thing, but technically, it's different. It can be an issue. Note that in 1989 Toyota redesigned this item to be more reliable. They are not interchangeable without doing a plenum/TB swap.

The two items that control cold start are the cold start time switch, and the cold start injector. You have already cleaned the injectors. I had a cold start issue because my injectors were leaking and flooding the manifold with gas over night.

I can feel a slight irregular "poof" that seems to correlate with a subtle stumble at idle.

My 22re also has this slight stumble at idle, occasionally noticed at faster rpm under no load, but not under road use. I've always considered it normal and never worried about it.

As far as the hesitation while shifting, I would look at the dashpot. It's job it to keep the idle up between shifts. If it drops all the way down to 750 between shifts this could be the problem.
 
Joined
Jul 31, 2007
Messages
493
Location
San Diego North
22re's can be frustrating as they age. seems like any slight change away from the stock "provisioning" will have a negative effect elsewhere. I didn't see you talk about the TPS but that's always fun to try to adjust correctly. Also most mods tend to increase the vacuum and can cause the EGR to open a bit too soon so I like to disconnect and plug the modulator hose to the EGR valve while troubleshooting. If the EGR is causing an issue, you can put some kind of restrictor in the hose between the modulator and the valve or restrict the flow at the EGR gasket on the plenum.
 

IslandJ

SILVER Star
Joined
Aug 18, 2014
Messages
1,052
Location
Los Angeles
Thanks for that correction @pappy ! This should help my internet searches.
As far as the hesitation while shifting, I would look at the dashpot. It's job it to keep the idle up between shifts. If it drops all the way down to 750 between shifts this could be the problem.
Its a hesitation/stumble while at a steady cruising speed


Ah yeah the EGR! That was a nightmare on my old fj60. When I get under the hood next Ill disable it and see how it goes.
And thanks for the TPS suggestion. Ill do some searching on that.
 

IslandJ

SILVER Star
Joined
Aug 18, 2014
Messages
1,052
Location
Los Angeles
Pulled the toyota 22230-35010 auxilary air valve and it looks to be in constant closed mode. Tested the ohm’s and it tested fine but when I got wire there’s no nada.
My two options from as far as I understand is buying used or swapping out the plenum and throttle body for an update version, as @pappy mebtioned. If I swap the throttle body and plenum then I’ll also need new injectors?
 

IslandJ

SILVER Star
Joined
Aug 18, 2014
Messages
1,052
Location
Los Angeles
AH okay. The injectors only have a couple 1000 miles on them after they were rebuilt. Thanks @pappy
Going to source a new Plenum and throttle body.
 

IslandJ

SILVER Star
Joined
Aug 18, 2014
Messages
1,052
Location
Los Angeles
Update: In stalled a used AAV and the cold start high idle came back. Super stoked that its not dying on start up.
Still having a slight hesitation at cruising speed and at a stop. Engine just reached its 1000 mile marker on the rebuild, fresh oil change.
Ill see if things settle a bit more then start testing more items.
 

Users who are viewing this thread

Top Bottom