Alternator?

This site may earn a commission from merchant affiliate
links, including eBay, Amazon, Skimlinks, and others.

Joined
Oct 11, 2010
Threads
44
Messages
612
Location
Calgary, Canada
Today driving to the trains station notice the volt gauge was very low so I turned around quickly and went back home. I started to feel the 80 was loosing power and when i parked it was idling rough and my capacitor for the sub was reading 0.00, shut down the car and as i expected it didn't start again and the capacitor was reading 9.14v.
The thing is that i bought a new alternator on December and when the last one died there was a red light on the dashboard and now i don't have it.
What you guys think? :confused:
 
Also forgot to mention that I got new batteries at the same time I bought the alternator
 
Ok so I got a battery from my moms 06 Sienna at first it showed me 12.43 volts then started the cruiser and dropped to 12.20 something and stayed there. Turned on the low beams and dropped a bit more but never went up to the normal 13.5 to 15.1 that the Haynes manual, what i dont understand is if the alternator is not charging the battery why is the red light in the dashboard not on like the last time the old alternator died?
 
It sounds like your battery died and the alt is working. Clean all connections and Use delectric on all connections after cleaning them before you reconnect it all.
Charge your batt and have it checked at Autozone or Napa..,,,,, have them load test it. Check your alt while your there with the other battery in it. The red light won't come on if it is charging if I recall.
Good luck.
 
I got the alternator tested, it did not pass. The good thing is that is under warranty for a year so Mean Green people is going to see if they can repair it or is just better to send me a new one.
The bad is that i had to pay for shipping.
 
I got the alternator tested, it did not pass. The good thing is that is under warranty for a year so Mean Green people is going to see if they can repair it or is just better to send me a new one.
The bad is that i had to pay for shipping.

You'll be replacing it in 6 months...again.
Get an OEM unit.
 
Or, if I can figure out a way to mount the alternator out of my parents' 100-series when I change it out in the next few weeks you could go that route...
 
Or, if I can figure out a way to mount the alternator out of my parents' 100-series when I change it out in the next few weeks you could go that route...

Isn't that the same as the Sequoia alternator? There are custom brackets you can get to install a later model, higher output OEM alternator.
 
Do not follow that lionk, it is for the fzj and from your sig i see you have an fj 3fe. My alternator just s*** the bed in my 92 and there was no warning or light. I swapped it out and now it is working fine. Make sure your dual battery system is done correctly with a proper isolator. Also you may need to reevaluate how much power you need. It sounds like your rig has a great deal of electronics.


Also, you said you noticed the problem when you saw your cap reading 9.14 volts. To me, that either means the problem has been going on for a while or your battery was under and extremely high load when you saw the 9 volts. I dont even think my truck goes down to 9 volts when it is cranking. So from that alone it tells me that this isnt an all of a sudden thing and that your battery hasnt been charging for a while.
 
Last edited:
Check the alternator fusible link and the voltage at the B+ (should be >13V) and Ign terminals (should be battery voltage) at the alternator when running.
 
So today i called napa and asked for the price of an alternator and they have with external fan or internal fan? Witch one should i get?
 
So today i called napa and asked for the price of an alternator and they have with external fan or internal fan? Witch one should i get?

One from Cruiser Dan...
 
You could upgrade to the 90 amp alternator as well,
https://forum.ih8mud.com/80-series-tech/271394-3fe-90-amp-alternator.html

I choose this route, because the alternator can be rebuilt later down the road, like in 2030 if it last 20 years like the original OEM unit. I actually cracked the alternator putting it in by stupidly cranking on the pivot bolt, but over a year later its still fine.
https://forum.ih8mud.com/80-series-tech/375278-3fe-90-amp-upgrade-round-1-failed.html

Alt, new upper bar mount, a little grinding, and 90 amp 3FE powwa!:steer:
 
Eicca said:
One from Cruiser Dan...

X2. Get it from Dan. Make your life easier.
 
So today i called napa and asked for the price of an alternator and they have with external fan or internal fan? Witch one should i get?

The one with the external fan is the direct swap 80 amp alt. The one with the internal fan is the 90 amp which needs a bit of messing around to make ti fit. Ive need and alternator in a pinch and got the external fan from autozone and it has been running in there for a while. I didnt give them the old one and i rebuilt my OE and now i have that one sitting as a spare.
 

Users who are viewing this thread

Back
Top Bottom