1985 22re

Joined
Jul 31, 2022
Messages
11
Location
North Ga
I have recently acquired a 1985 4x4 Toyota pickup which 22re. I have a couple other pickups with the 22r. This is my first efi. So I’m am trying to get it straightened out and running decent. When I first got it I had to replace the fuel pump to get it running, got it started but wasn’t running great had a miss. So I checked plugs and wires all seemed to work right checked compression it was good enough. Was going to check timing but not sure what wires to jump since someone before I got it pulled the wires out of a couple plugs on driver side fender under the hood. But still wanted to turn the dizzy to see how it changed so loosened the bolt and it wouldn’t turn. So I used a rubber hammer to tap on it and try to get it out still didn’t work. The PO put a bolt through bracket beside the dizzy that was too long and it screwed through the dizzy housing slightly. When I took the bolt out the dizzy pulled out and the part of it where the o ring is was completely broke all the way around so I put it back in and never tried starting it till I got a new TPS and put on it and when I tried to start it then it wouldn’t start. Finally kept try and giving it gas till I got it barely started and it will not rev up to even 1000 rpm’s. Could it be the dizzy or something else or a number of things? Thanks I’m advance.
 

pappy

photosynthesizing
Moderator
Joined
Oct 7, 2003
Messages
11,867
Location
Too far north. Too far east.
PICTURES will help us understand what "The PO put a bolt through bracket beside the dizzy that was too long and it screwed through the dizzy housing slightly. When I took the bolt out the dizzy pulled out and the part of it where the o ring is was completely broke all the way around" means.

As far as the service connectors ... I can't fix stupid over the Internet ... but maybe you can. Here is a pic of the two service connectors on an 85. The red circle is the fuel pump diagnostic connector. The blue circle is the connector used to time the dizzy, and pull codes.

If the PO removed those two connectors, I can't wait to hear what else they removed thinking they were smarter than a Toyota engineer.

Test connectors-sm.jpg
 

pappy

photosynthesizing
Moderator
Joined
Oct 7, 2003
Messages
11,867
Location
Too far north. Too far east.
Oh, and where the heck are my manners. This is your first post in our slice of MUD. :flipoff2: <- official MUD welcome.
 
Joined
Jul 31, 2022
Messages
11
Location
North Ga
I will have to try and get pics. It’s the bracket on front of the motor right in front of the dizzy. The wires are there but the plug it’s self have been pulled off and are gone. I probably need a device manual so I know what color wire are what. There is a few things that aggravate me and one is to butcher the wires on a vehicle.
 

pappy

photosynthesizing
Moderator
Joined
Oct 7, 2003
Messages
11,867
Location
Too far north. Too far east.
Fuel Pump Check Connector: Green + White with a black trace.
Check Connector: Brown + Green with a yellow trace.
 

pappy

photosynthesizing
Moderator
Joined
Oct 7, 2003
Messages
11,867
Location
Too far north. Too far east.
You need a new distributor.

As far as the wires. I've doctored your pic. The check connector used to time the truck and pull codes is in the blue box. Those wires should not be touching. The fuel pump test connector is in red, and appears to be OK. The other two wires go to a three wire connector. Underneath the two wires in the pic you can see a cut black wire. If you look at my pic the yellow connector is just to the right of the red circle. I have no idea what it is for.

There is also a single wire under this mess, right under the black wire. It should be a yellow connector. You can see it in my pic just under the wire bundle. Again, no idea what it does.

check connectors-2.jpg
 
Joined
Jul 31, 2022
Messages
11
Location
North Ga
Pappy thanks for the help. I greatly appreciate it. Do you think the dizzy may be what’s causing the no running issue?
 
Joined
Jul 31, 2022
Messages
11
Location
North Ga
Do you happen to know what this connector may be?
9E85D2F8-EC9C-40FE-B59E-058EE155BC5F.jpeg


And what about these plugs on passenger side under intake plenum?
0E8D7715-6F2E-4AEA-90A5-8AEAEF5D32B7.jpeg
 

pappy

photosynthesizing
Moderator
Joined
Oct 7, 2003
Messages
11,867
Location
Too far north. Too far east.
Not on my truck. PO installed. You will need to chase the wires.
 
Joined
Jul 31, 2022
Messages
11
Location
North Ga
The plug and wires on top of valve cover got the double plug and single plug that’s also pictured above. They are located on passenger side under intake plenum back toward the firewall.
 

pappy

photosynthesizing
Moderator
Joined
Oct 7, 2003
Messages
11,867
Location
Too far north. Too far east.
Any recommendations on best wiring diagram?
Factory Electrical Wire Diagram manual. the 1986 manual works great. You can get them new on ebay. I think I paid $35.
 

Users who are viewing this thread

Top Bottom