1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

sucky turning @ low rpms

Discussion in '40- & 55-Series Tech' started by rusmannx, Jul 21, 2003.

  1. rusmannx

    rusmannx

    Messages:
    1,159
    Likes Received:
    13
    Joined:
    Feb 9, 2002
    Location:
    HIT IT!
    my power steering doesn't seem to give the juice when idleing. i've been reading these techs about increasing pressure and flow.
    is there any downside to this?
    will it still handle on the road at highway speeds?
    i'm only running 33's, but i always find myself reving a little to get the tires to turn with any force.
     
  2. 73lndcrsr

    73lndcrsr SILVER Star

    Messages:
    744
    Likes Received:
    4
    Joined:
    May 28, 2002
    Mine is the same way. I have come to the conclusion that my steering box is not working properly. I am trying one of those conditioning additives to see if it helps. I hope so, I really don't want to replace the box.
     
  3. rusmannx

    rusmannx

    Messages:
    1,159
    Likes Received:
    13
    Joined:
    Feb 9, 2002
    Location:
    HIT IT!
    i haven't thought about the box being an issue...
    i don't know how to troubleshoot the situation, i just figured my pump wasn't pumping hard enough or moving enough flow.
     
  4. roscoFJ73

    roscoFJ73

    Messages:
    13,081
    Media:
    3
    Likes Received:
    223
    Joined:
    Jul 22, 2003
    Location:
    Perth Western Australia
    I think the pump can be pressure tested in the car.If the pressure is down it probably needs new vanes. You could probably check the steering box by lifting the front wheels off the ground and getting an asisstant to turn the steering wheel with the engine off and see if it feels too tight. Listen for noise and place your hand on the steering box to feel for any grating
     
  5. hammerhead

    hammerhead

    Messages:
    1,995
    Likes Received:
    0
    Joined:
    Jul 5, 2003
    Location:
    Central, Utah
    What pump are you running?
    What steering box?
     
  6. sfrolich

    sfrolich

    Messages:
    187
    Likes Received:
    0
    Joined:
    Jan 23, 2003
    Location:
    San Jose, CA
    I had the same problem and it turned out to be a bad PS Pump.