Waeco CF50 issues - help wanted

Discussion in 'Expedition Builds' started by BMThiker, Jan 11, 2012.

  1. LandCruiserPhil

    LandCruiserPhil Peter Pan Syndrome Supporting Vendor

    Messages:
    21,701
    Media:
    55
    Albums:
    3
    Likes Received:
    12,375
    Joined:
    Mar 10, 2004
    Location:
    Scottsdale Arizona
    Thanks I have the 'B' design with the digital display. The display read -18 and the fridge runs but never shuts off and the temp display never changes. So far I changed the board and tested a new thermister with no change.
     
  2. BMThiker

    BMThiker I aim to misbehave Moderator SILVER Star

    Messages:
    8,438
    Media:
    50
    Albums:
    2
    Likes Received:
    6,998
    Joined:
    Sep 19, 2006
    Location:
    Atlanta
    Mine went through that phase once. It would only run turbo mode. I regulated it on that trip by unplugging it. I gave up on mine after throwing about $150 in replacement parts at it. Still have it if anyone wants parts off of it (make an offer). I'll have to de-solder 2 wires on the main PCB, but the controller/display PCB is easily unplugged.
     
  3. LandCruiserPhil

    LandCruiserPhil Peter Pan Syndrome Supporting Vendor

    Messages:
    21,701
    Media:
    55
    Albums:
    3
    Likes Received:
    12,375
    Joined:
    Mar 10, 2004
    Location:
    Scottsdale Arizona
    Do you have the board in the picture below available?

    IMG_2807.JPG

    It is inside the pictured plastic box

    [​IMG]
     
    Last edited: Aug 12, 2015
  4. BMThiker

    BMThiker I aim to misbehave Moderator SILVER Star

    Messages:
    8,438
    Media:
    50
    Albums:
    2
    Likes Received:
    6,998
    Joined:
    Sep 19, 2006
    Location:
    Atlanta
    That's the only board I didn't replace because I couldn't find a source for it. I replaced the main PCB mounted to the end of the casing where the power plugs into and the upper control PCB.

    So, yes, I have the original, but I suspect it is the primary failure in my case.
     
  5. LandCruiserPhil

    LandCruiserPhil Peter Pan Syndrome Supporting Vendor

    Messages:
    21,701
    Media:
    55
    Albums:
    3
    Likes Received:
    12,375
    Joined:
    Mar 10, 2004
    Location:
    Scottsdale Arizona

    I found many sources but pricey
    Im beginning to rethink going further

    What is the part number on your board/black box?

    IMG_2812.JPG
     
  6. BMThiker

    BMThiker I aim to misbehave Moderator SILVER Star

    Messages:
    8,438
    Media:
    50
    Albums:
    2
    Likes Received:
    6,998
    Joined:
    Sep 19, 2006
    Location:
    Atlanta
    I'll have to check. Been a while since I even looked at it. I don't think its visible in any of my previously posted pics either.
     
  7. LandCruiserPhil

    LandCruiserPhil Peter Pan Syndrome Supporting Vendor

    Messages:
    21,701
    Media:
    55
    Albums:
    3
    Likes Received:
    12,375
    Joined:
    Mar 10, 2004
    Location:
    Scottsdale Arizona
    LMK
     
  8. LandCruiserPhil

    LandCruiserPhil Peter Pan Syndrome Supporting Vendor

    Messages:
    21,701
    Media:
    55
    Albums:
    3
    Likes Received:
    12,375
    Joined:
    Mar 10, 2004
    Location:
    Scottsdale Arizona
    I found a new black box board at almost 1/2 the price in the USA including shipping from Poland:hmm: should I be scared
     
    BMThiker likes this.
  9. LandCruiserPhil

    LandCruiserPhil Peter Pan Syndrome Supporting Vendor

    Messages:
    21,701
    Media:
    55
    Albums:
    3
    Likes Received:
    12,375
    Joined:
    Mar 10, 2004
    Location:
    Scottsdale Arizona
    I have parts available for CF-50
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.