The MUD 100 series Photos thread

e9999

You want to do what...?
Moderator
 
 
Joined
Sep 21, 2003
Messages
16,618
Location
US
Hendrik, this fella with the slanted panel up top, has he ever had issues with rocks dinging the glass when driving?
 

MongooseGA

Learns things the hard way
SILVER Star
Joined
Jul 9, 2017
Messages
774
Location
Atlanta GA
Took a Sunday trip out to some trails in N GA. Got her high-centered twice (over and back over the same mound) and got to work out my new Smittybuilt. Worked well. Had a great, short day and was home in time to have the mud and cow pies pressure washed off of Gerry before Sundown.

Attach15231_20190203_190532.jpg


Attach15228_20190203_190517.jpg


Attach15226_20190203_190504.jpg


Attach15225_20190203_190501.jpg


Attach15224_20190203_190459.jpg
 

ClassyJalopy

Tryna figure it out.
SILVER Star
Joined
Jun 4, 2018
Messages
239
Location
Madison, WI
Took a Sunday trip out to some trails in N GA. Got her high-centered twice (over and back over the same mound) and got to work out my new Smittybuilt. Worked well. Had a great, short day and was home in time to have the mud and cow pies pressure washed off of Gerry before Sundown.
Excellent pics. I have the same winch sitting in my garage waiting to be installed. @87warrior sold me his hidden winch mount that I have just been to slow to mount. The idea is to have it all set up before the next outing.
 

MongooseGA

Learns things the hard way
SILVER Star
Joined
Jul 9, 2017
Messages
774
Location
Atlanta GA
FYI, I noticed a faint amount of smoke coming from my control box when using the remote to winch out. Probably just had it running too long. Could also be some assembly lube burning off? Idk, either way, I recommend manually pulling the cable out. Less time, no risk of smoke. I'll contact the vendor this week and confirm if it's a big concern or not.
 
Top Bottom