power steering help (1 Viewer)

Joined
May 10, 2006
Messages
831
Location
San Jose
 
 
Hi,

So I replaced my leaky power steering pump yesterday with a brand new oem one from the stealer and also installed one of those tranny coolers upfront inplace of the paperclip looking one. I followed the proceedure on bleeding the system and it seems to have worked because I don't get the "groan or the whine" when I turn my wheels. what I do hear is a strange ticking like noise coming from the new power steering pump, I know it's the pump because I can also feel it and hear it when the engine is on. I used the mobil dte light fluid as recommended by some here.

Has anyone experienced or heard this before?

Thanks

-Juan
 
Joined
May 10, 2006
Messages
831
Location
San Jose
 
 
Well I bled the system some more yesterday and the pump sounds the same. It's more of a rattle than a ticking. I can feel the rattle when I put my hand behind the steering pump.
 
Last edited:
Joined
May 10, 2006
Messages
831
Location
San Jose
 
 
Well i got the gear and installed it but I still hear the rattle. The old gear was a little damaged but not much. I did however remove the pump and started the truck, the engine was quiet and no rattle noise. So now i'm thinking I either have a bad pump, bad drive gear or maybe it doesn't like the mobil 24 hydraulic oil. i'm up against the wall with this.

-juan
 
Joined
Jul 20, 2004
Messages
24,774
Location
Chandler, AZ
 
 
Well i got the gear and installed it but I still hear the rattle. The old gear was a little damaged but not much. I did however remove the pump and started the truck, the engine was quiet and no rattle noise. So now i'm thinking I either have a bad pump, bad drive gear or maybe it doesn't like the mobil 24 hydraulic oil. i'm up against the wall with this.

-juan
I agree that you have ether a bad gear or pump. When the new gear was instilled, is there any change in the sound? How was the gear damaged? If it had a tooth problem, there is the possibility that it transfered the damage to the drive gear. When you had the pump out, did it turn smooth? May be able to locate the sound with a stethoscope?

I have run Mobil DTE in tons of Toyota pumps for decades with zero issues.
 
Joined
May 10, 2006
Messages
831
Location
San Jose
 
 
yeah pump turned smooth no issues. the other gear didn't have bad damage it was very minimal. But that made me swap out the gear yielding no results. so yes I think I might have a bad drive gear or pump. What are the chances that it could be a bad pump? This is new from the dealer.
 

landtank

SILVER Star
Joined
Mar 27, 2003
Messages
19,852
Location
Groveland MA
 
 
 
I've run into a few very bad oil pump bushings that allow the drive gear to the PS pump to wobble which could produce a noise.

And yes I have made a few of these bushings and sold them.

Just to beat Tools to the punch.
 
Joined
May 10, 2006
Messages
831
Location
San Jose
 
 
I've run into a few very bad oil pump bushings that allow the drive gear to the PS pump to wobble which could produce a noise.

And yes I have made a few of these bushings and sold them.

Just to beat Tools to the punch.
I might have to look into this option Rick.

thx
Juan
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom