New Procar Rally Seats: One thing led to another and another and another....... (1 Viewer)

Joined
Jun 30, 2016
Messages
263
Location
Calif
Well... I waited six weeks to finally get the seat adapters for my Procar seats and this is what they sent me. The part #s I ordered were 81598/81599. This is for a 1/73 which by there chart is the correct part #. Unfortunately this is what I received. It doesn't look like anything you installed, just won't work ho hum. Very frustrated

IMG_0286.JPG


IMG_0287.JPG
 

GA Architect

SILVER Star
Joined
Feb 14, 2014
Messages
3,489
Location
Woodstock, GA
Is Pro-Car the supplier of those brackets?

Architect, did you use those?
In my '77, I used the #81618 & #81619 Procar brackets. I did have to waller-out the passenger side, front right two holes a bit. Hence the large fender washers. Your brackets should look like the picture below.

img_0550-jpg.942264
 
Joined
Dec 30, 2015
Messages
350
Location
Michigan
I have a little time before I pull the trigger on this project but every time this thread pops up I get sucked in. Thanks for the responses, can't wait to put those in.
 
Joined
Jun 30, 2016
Messages
263
Location
Calif
See post #64 below....Call them on Monday and they should get you covered quickly.
I did call them today. They said that I received the right parts for my year cruiser 1/73. So somethings wrong with there order spec. I sent a email to the guy at SCAT with all the centers of the mounting holes and pics. Hopefully they can get it straitened out. It's obvious to me that it has to be the part # you spec out. It's just wrong on the website for my 40.
Fingers crossed! And I was So excited to mount my new seats to.
 
Joined
Jun 30, 2016
Messages
263
Location
Calif
I did call them today. They said that I received the right parts for my year cruiser 1/73. So somethings wrong with there order spec. I sent a email to the guy at SCAT with all the centers of the mounting holes and pics. Hopefully they can get it straitened out. It's obvious to me that it has to be the part # you spec out. It's just wrong on the website for my 40.
Fingers crossed! And I was So excited to mount my new seats to.

Ok just an update on part# from SCAT for seat adapters. On there website the part #s that they provide for the Procar seat adapters for my 1/73 fj40 is 81598 and 81599. After talking with one of the seat adapter reps and sending him my bolt centers and some pics, we have come to the conclusion that the web reference to the part # is wrong. The correct part # for my application is #81618/81619.
Just a not if you have a 73 fj40 make sure to call them with bolt center dimensions before ordering.
 

JohnnyC

Long ago TLCA# 2231
Joined
Jun 17, 2005
Messages
17,027
Location
UpState Ny, Wells Me
I was really enjoying reading from the beginning... with all the little extra stuff you've been doing it looks great... but... your jack is still black ... yuck :meh:

Everything else looks great :)
 
Joined
May 11, 2002
Messages
631
Location
twin cities
I would think this would work with an AQUALU tub?

any one have any experience with this and perhaps tuffy-type center box?

1978 fj40
 

Users who are viewing this thread

Top Bottom