LX470 Vibration and impact feel at all speed (1 Viewer)

Joined
May 5, 2021
Messages
1
Location
Bahrain
Hi there, I have a GCC spec 2007 LX470 with a conventional LC100 suspension set up (AHC was cancelled). It's been a good long while since the AHC delete and the ride was very smooth but for the past couple of months the car has been very harsh on even the tiniest road imperfections. Even in perfectly smooth roads the car feels like it's hitting small bumps and there is some vibration and feelings of impact, even when the road is perfect and clean. No matter what speed I go on that can be felt through the whole car. The steering wheel also has some vibration even after re-balancing and aligning all wheels.

I tried many different tire PSIs to see if that was the issue but it didn't seem to affect the ride much. I'm running 285/65r17 (OEM spec is 275/65). I've changed the wheel bearings, bushings, tie rods, CV axle inner and outer boots, re-torqued all bolts, put new OEM conventional shocks but the car still has vibration and is very harsh on small bumps and lane breakers, even though it's really smooth on speed bumps and big dips. The car has no lift, every thing is stock. I've had my mechanic check the car and he said everything seems fine. My coil springs and TBs are the OEM conventional LC parts as well and they are only 2 years old with very little wear. I rarely ever go off-road.

I was hoping if anyone had any insight as to why this is happening, or any pointers on what to check maybe? Thank you in advance and any input will be very much appreciated.
 
Joined
Nov 8, 2020
Messages
23
Location
Louisiana and Dubai
Check steering column. Mine is GCC spec and did the same thing when I purchased. Had play inside column that felt like front suspension issue. It also had slight play in steering.
 

Users who are viewing this thread

Top Bottom