Getting fuel at fuel rail but no fuel into motor (1 Viewer)

Joined
Aug 29, 2020
Messages
3
Location
Tennessee
Hey. So I was having a no start issue due to no fuel. I have replaced the fuel pump, fuel filter, fuel pressure regulator, fuel dampener, and the EFI relay. I am getting fuel at the dampener but still won’t start. I can get it to start with starting fluid but won’t stay running or start on it’s own. I am at a complete loss
 
Joined
Aug 29, 2020
Messages
3
Location
Tennessee
Hey. So I was having a no start issue due to no fuel. I have replaced the fuel pump, fuel filter, fuel pressure regulator, fuel dampener, and the EFI relay. I am getting fuel at the dampener but still won’t start. I can get it to start with starting fluid but won’t stay running or start on it’s own. I am at a complete loss
 
Joined
Dec 8, 2006
Messages
9,730
Location
New Jersey
Hey. So I was having a no start issue due to no fuel. I have replaced the fuel pump, fuel filter, fuel pressure regulator, fuel dampener, and the EFI relay. I am getting fuel at the dampener but still won’t start. I can get it to start with starting fluid but won’t stay running or start on it’s own. I am at a complete loss
You gave no information about your vehicle, but you mentioned "fuel damper" so I assume you're referring to a 3FE engine. A "dampener" is a wet towel.
If you're getting fuel to the rail, then it sounds like the injectors are not firing.
Is the CEL illuminated with the key in the ON/RUN position before you crank the starter? No CEL=no start.
With the key in the ON/Run position are you seeing +12 at the 7.5amp IGN fuse in the fuse panel by the driver's left knee?
 

Users who are viewing this thread

Top Bottom