Builds Dave's 80

davidp14

SILVER Star
Joined
Mar 24, 2017
Messages
1,130
Location
Staunton, VA
So I finally joined the club last week. After a couple of years of saying I'd eventually get one, I found a nice 3x locked 96 LC. 170k miles, everything works, very little rust, and she runs like a top. I felt like I got a pretty good deal too.
Of course she's 22 years old so there are issues, (we'll cover those individually) but nothing major AFAIK.
I'm posting here as a "build thread" as a way of documenting my work.
Pics:

rps20180704_125058.jpg


rps20180704_125012.jpg
 
Last edited:

davidp14

SILVER Star
Joined
Mar 24, 2017
Messages
1,130
Location
Staunton, VA
First couple of "mods".
So I didn't like the running boards and the aftermarket hitch was really the only part of the car that has serious rust so both these things had to go.

Like I said the hitch was really rusted and required a lot of PB blaster, a 2lb hammer, a breaker bar, and a lot of elbow grease to convince it to go but in the end I won.

rps20180708_091606.jpg


rps20180708_091538.jpg
 

davidp14

SILVER Star
Joined
Mar 24, 2017
Messages
1,130
Location
Staunton, VA
I also took the rear seats out, no pics but you've seen that before.

Then I sprayed the rear sliders with silicone spray and now they open and close nicely. Make sure you wipe up overspray immediately this stuff will stick to your paint.

We had a great supervisor who kept us on task.

rps20180708_091501.jpg


rps20180708_091518.jpg
 
Last edited:

davidp14

SILVER Star
Joined
Mar 24, 2017
Messages
1,130
Location
Staunton, VA
Nothing too crazy yesterday. I de-pinstriped, unpined? Anyway. The pinstripes on my LC are pretty much done. Only 2 of 4 doors have them left.
I used a 3m eraser wheel to do the deed. It worked pretty well. I've seen folks use razors to get them off but that made me nervous. The eraser makes a mess and leaves a waxy stripe in its trail but that supposedly comes off with rubbing alcohol.

Also slapped some new wipers on.

rps20180709_083738.jpg


rps20180709_083804.jpg


rps20180709_083636.jpg


rps20180709_083707.jpg
 
Joined
Feb 18, 2015
Messages
444
Location
North Georgia
Is that a black 80 sir. If it is it's the best color cause mine is lol. I quit counting the dollars a year or so ago I added it up one time and no I have more in rebuild and goodies than what I gave for the rig. NWTI bumper is almost finished up now I guess I can save for something else. Maint. was a boat load of money. But my cruiser has over 400,000 miles so it needed quit a bit. surprisingly everything still works electrically except the antenna. Oh and if it is black no clear coat to peel off. Kinda hard to tell in the pics on my crappy phone. Enjoy it they are beastly in stock form let alone outfitted with a lift and good tires.
 

davidp14

SILVER Star
Joined
Mar 24, 2017
Messages
1,130
Location
Staunton, VA
@gabriel71 yup she's black and beautiful.

I spent most of today chasing a dead rear pass turn signal. Its not getting any power. I can only guess it had something to do with the hitch harness I pulled this weekend but I can't find the source. I'll work on it some more this weekend.

On a brighter note, my floor mats showed up today. :)

rps20180710_165741.jpg
 

davidp14

SILVER Star
Joined
Mar 24, 2017
Messages
1,130
Location
Staunton, VA
Fixed my rear turn signal but not without destroying the connector :slap:
Installed my new head unit and backup camera. Install went really well and the camera works great. I did drill one hole in the tailgate but it pretty small and my buddy had a perfect sized grommet to make it look oem. My boys will be driving this too so I wanted to give them every advantage I could.

rps20180715_145455.jpg


rps20180715_145421.jpg


rps20180715_145351.jpg
 

davidp14

SILVER Star
Joined
Mar 24, 2017
Messages
1,130
Location
Staunton, VA
Fixed my occasional "oh sh#$, no brakes" problem. After some searching here, I figured out that the likely culprit was the brake booster check valve. So I ordered the valve and grommet and it took about 10 minutes to fix. The original rubber grommet was hard as a rock and basically fell apart as soon as I touched it.
Now she stops on a dime!

rps20180717_110554.jpg


rps20180717_110437.jpg
 
Joined
Jul 4, 2017
Messages
1,032
Location
Charlotte NC
@gabriel71 yup she's black and beautiful.

I spent most of today chasing a dead rear pass turn signal. Its not getting any power. I can only guess it had something to do with the hitch harness I pulled this weekend but I can't find the source. I'll work on it some more this weekend.

On a brighter note, my floor mats showed up today. :)

View attachment 1741397
Damn.... fancy mats. I bought a set of all weather ones off of Groupon. They may not fit perfectly but they do the deed.
 
Joined
Jul 4, 2017
Messages
1,032
Location
Charlotte NC
Fixed my rear turn signal but not without destroying the connector :slap:
Installed my new head unit and backup camera. Install went really well and the camera works great. I did drill one hole in the tailgate but it pretty small and my buddy had a perfect sized grommet to make it look oem. My boys will be driving this too so I wanted to give them every advantage I could.

View attachment 1744929

View attachment 1744930

View attachment 1744931
That binnacle looks like it has a s*** ton of spit juice on it.
 

davidp14

SILVER Star
Joined
Mar 24, 2017
Messages
1,130
Location
Staunton, VA
Apparently the CDl switch was more commonly found on the nonlocked 80s.

I could add it though I saw the plug when I was putting the new HU in.

I can take a pic if you're concerned about posterity. :flipoff2:
 
Joined
Mar 17, 2015
Messages
1,114
Location
Yuma, Az
Apparently the CDl switch was more commonly found on the nonlocked 80s.

I could add it though I saw the plug when I was putting the new HU in.

I can take a pic if you're concerned about posterity. :flipoff2:
pre 1fzfe had the CDL switch. for some reason they didn't put it on the newer ones. the plug is behind the dash panel and you can buy one and plug it right in. x3 locked is the cdl and the rotary switch left of the steering wheel. anyway, you got a nice ride. look into the 7 pin mod and pick up the cdl button...
 

Users who are viewing this thread

Top Bottom