1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Anyone near Idaho Falls, ID that has a spare 3FE ECU or AFM?

Discussion in '80-Series Tech' started by LhPickle, Feb 13, 2018.

  1. LhPickle

    LhPickle

    Messages:
    69
    Likes Received:
    75
    Joined:
    Mar 23, 2016
    Location:
    Idaho Falls
    I am trying to trouble shoot, my 1991 3FE and I think I have it narrowed down to either the AFM or the ECU. I don't really want to buy new/used ones, if I don't actually need to. So I am looking try swapping them out to see if that solves my problems. Iv'e gone as far as my non-electrically minded brain can go working through @jonheld diagnostic...

    I have No CEL with key in the on position and it wont start. I spray starting fluid in the air filter and it acts like it wants to start, otherwise it just cranks with no starting fluid.

    Replaced the following:
    Fusible Link
    EFI Relay Under the Hood
    Spark Plugs and Wires
    Distributor Rotor and Cap
    Fuel Pump and Fuel Filter
     
  2. baldilocks

    baldilocks GOLD Star

    Messages:
    3,886
    Likes Received:
    3,545
    Joined:
    Jan 29, 2014
    Location:
    Northern California
  3. Tools R Us

    Tools R Us

    Messages:
    22,082
    Likes Received:
    3,569
    Joined:
    Jul 20, 2004
    Location:
    Chandler, AZ
    Does it have power to the ECU? If not it's not going to start, changing the ECU isn't likely to help.
     
  4. ginericLC

    ginericLC Wagon Wheeler! SILVER Star

    Messages:
    7,245
    Likes Received:
    365
    Joined:
    Jan 29, 2003
    Location:
    MH, IDaho
    I have a 91 3FE ECU for sale over in Mountain Home. $112 shipped to ID Falls.
     
  5. LhPickle

    LhPickle

    Messages:
    69
    Likes Received:
    75
    Joined:
    Mar 23, 2016
    Location:
    Idaho Falls
    I don't have a FSM, how do I check to make sure it has power? What do I need to do to verify that?
     
  6. LhPickle

    LhPickle

    Messages:
    69
    Likes Received:
    75
    Joined:
    Mar 23, 2016
    Location:
    Idaho Falls
    interested if I can validate that the ECU is the problem
     
  7. Tools R Us

    Tools R Us

    Messages:
    22,082
    Likes Received:
    3,569
    Joined:
    Jul 20, 2004
    Location:
    Chandler, AZ
    Need to run the voltage checks at the ECU. I'm not much of a 3FE fan, so not sure these pinouts are correct. At least need to key on power, at the yellow/black circuit, connector C, pins; 1 & 7, full time power at red/yellow C 2. There should be a meter check list in the FSM.

    https://forum.ih8mud.com/threads/40...sm-for-a-hell-of-a-price.610994/#post-7851101
     
  8. jonheld

    jonheld

    Messages:
    6,974
    Likes Received:
    1,785
    Joined:
    Dec 8, 2006
    Location:
    New Jersey
    No CEL=No start
    Cranking the starter will do nothing but run down the battery.
    Replacing plugs/wires/rotor/cap/fuel pump/fuel filter will do nothing to help the issue.

    Lets back up a bit. Is this a sudden issue? Driving fine then stopped running?
    Were you doing maintenance under the hood and then it wouldn't start?
    Throw some history and backstory at us.
     
    beno likes this.
  9. Technician1985

    Technician1985

    Messages:
    164
    Likes Received:
    100
    Joined:
    Sep 18, 2017
    Location:
    WA
    It has spark but no fuel?
     
    LhPickle likes this.
  10. LhPickle

    LhPickle

    Messages:
    69
    Likes Received:
    75
    Joined:
    Mar 23, 2016
    Location:
    Idaho Falls
    It was running fine, we were driving on some forest service roads and we stopped and idled while looking at wildfife and it died. It started right back up and made it home just fine. I parked it in the driveway to hose down dirt and mud and it hasn't started again. I thought it might be a spark issue and I might have gotten water in the distributor when I was spraying off the suspension and knuckles. I honestly just pushed it in the garage and didn't make time to look at it for a couple weeks. I already had a bunch of parts to replace as part of the baseline. So i replaced the spark plugs, wires, distributor rotator and distributor cap, Fuel Pump, Fuel Filter, and Fusible Links. After it still wouldn't start I replaced the EFI Main relay under the hood and it still wouldn't start. I have 12v+ at the relay box and also at the little terminal in the engine compartment in front of the passenger.
     
  11. LhPickle

    LhPickle

    Messages:
    69
    Likes Received:
    75
    Joined:
    Mar 23, 2016
    Location:
    Idaho Falls
    I assume it has spark because when i spray ether/starting fluid in the air filter it ignites the starting fluid.
     
  12. jonheld

    jonheld

    Messages:
    6,974
    Likes Received:
    1,785
    Joined:
    Dec 8, 2006
    Location:
    New Jersey
    To clarify, you're seeing +12 on pin 8 of the diagnostic connector with the key in the ON/RUN position. Correct?

    CheckConnector.jpg
     
  13. TBDAZ

    TBDAZ

    Messages:
    60
    Likes Received:
    16
    Joined:
    Nov 17, 2013
    Sit back and take it all in the master is speaking. I had the same problem back in October. I did what your about to do and throw parts at it. Then John to me by my stupid little monkey hand and walked me through it. After I spent over $200 on parts, it turned out to be a bad wire coming of the AFM. A $1.50 fix. It looked like it had a slice in it. Down in close proximity of the distributor. Probably something I did at some point changing the oil or who knows. Something you may want to look at. Never did thank John for his help.
     
    BILT4ME and LhPickle like this.
  14. jonheld

    jonheld

    Messages:
    6,974
    Likes Received:
    1,785
    Joined:
    Dec 8, 2006
    Location:
    New Jersey
    A quick test for the AFM is to simply unplug it. If the CEL comes back on with it unplugged, then you have your culprit.
     
    Technician1985 and beno like this.
  15. beno

    beno 23424-23216 Moderator GOLD Star

    Messages:
    23,444
    Media:
    382
    Albums:
    29
    Likes Received:
    17,910
    Joined:
    Aug 28, 2004
    Location:
    Nederland, CO
    Sensei Held's name is "Jon". :)
     
    LhPickle likes this.
  16. LhPickle

    LhPickle

    Messages:
    69
    Likes Received:
    75
    Joined:
    Mar 23, 2016
    Location:
    Idaho Falls
    Yes.
     
  17. jonheld

    jonheld

    Messages:
    6,974
    Likes Received:
    1,785
    Joined:
    Dec 8, 2006
    Location:
    New Jersey
    Change Sensei to SomeGuy.
     
  18. jonheld

    jonheld

    Messages:
    6,974
    Likes Received:
    1,785
    Joined:
    Dec 8, 2006
    Location:
    New Jersey
    Did you disconnect the AFM and check for the CEL?
     
  19. jonheld

    jonheld

    Messages:
    6,974
    Likes Received:
    1,785
    Joined:
    Dec 8, 2006
    Location:
    New Jersey
    Fixed it for you...
     
    BILT4ME likes this.