80 Series charging travel trailer AGM batteries

jellis

SILVER Star
Joined
Apr 29, 2011
Messages
246
Location
Boulder, Utah
All the voltages I listed were at idle, sorry I didn't specify that. I checked at 1500RPM but it didn't change enough to bother listing separately.

The dash lights started staying on after I put in an aftermarket Terrain Tamer alt. This thread has some conversation about how this circuit actually works:
Help with Voltage Light after alt upgrade - https://forum.ih8mud.com/threads/help-with-voltage-light-after-alt-upgrade.455607/#post-6327069
When the key is turned on the light comes on because battery voltage is going through the light circuit to ground through the regulator and alternator. As the alternator spins up and produces voltage the light dims and goes out as there is now no ground through the regulator.
Another post says:
I change from the old external regulator type alternator to a new 100Amp internal regulated type, my light would stay on until I revved the engine to 2500 rpm and then would go out and stay out. I fixed the problem by putting a higher wattage bulb in the warning light

Basically a higher wattage bulb = more resistance.....V=IR, so lower voltage to kickoff the light. An LED is WAY less resistance than stock bulb so therefore requires a higher voltage output from the alt before the regulator grounds out and kills the light. But maybe this LED is screwing with the charge voltage aspect of the circuit as well? I'm not sure how the regulator in there really works.
 
Joined
May 16, 2021
Messages
2
Location
USA
I have replaced my old battery model with a NOCO Gen5x2 deep cycle battery charger. The installation process is simple. Since the old one was wired directly and the NOCO came with a 3-prong plug, I temporarily converted the AC line from the breaker box to a 3-prong outlet and plugged it in.
 

Users who are viewing this thread

Top Bottom