3FE runs for a moment then dies out

Joined
Feb 16, 2012
Messages
105
Location
Lincoln, NE
Hopefully someone can give me some advice on this. I have a 1992 FJ80 with the 3FE. It has always ran perfect for me the last 5 years or so I’ve had it. A few months ago I went on a side hill and it died out on me. I finally got it to start but from then on it will sometimes start right up and run for hours, other times it will start and die or sometimes not start at all. Currently I can’t get it to start anymore. I’ve been throwing parts at it but am running out of things to change. So far I’ve done the following based on advice from here.



New fuel pump, fuel filter

New MAF

New fuel pressure regulator

New spark plugs, wires, cap

Replaced the computer with another one

When it was running I would run my hand on all the wiring trying to get it to stall out, but never could. Everytime I check there is spark, I can loosen the banjo bolt where the fuel goes into the motor and fuel comes pouring out like it should. Anyone have any suggestions on what else to look for?



Thanks.
 
Joined
Jan 17, 2005
Messages
6,197
Location
Southern Colorado
You have done a lot so far. When it dies, have you tried Ether starting fluid to get it re-started? If it fires on that, then you know it's fuel and not spark. You might also remove/inspect/test/replace any fuses related to fuel or ignition. I believe there is an infamous 3F fuel relay that you should check, too - search here for info.
 

60Works

60 Series Iron Works
Joined
Sep 28, 2009
Messages
1,570
Location
NH
You can check for 12V to the fuel pump via the access panel above the tank. Or install a pressure gauge at the cold start injector.

I have a rusty 62 that won't run or start on hills unless the tank is more than half full. Fill the tank and it fires right up.
 
Joined
Apr 7, 2005
Messages
1,309
Location
Afton VA
Google EFI Main relay overheating issues for the 3FE FJ80. They are notorious for overheating. I used to carry a spare when I had one.
GL

Edit - already mentioned by @SteveH :)
 
Joined
Jan 4, 2011
Messages
5,280
Location
Vermont

Engineer8000

CAPE FEAR ELECTRONICS
SILVER Star
Joined
Aug 16, 2019
Messages
1,257
Location
SOUTHPORT NC
Website
forum.ih8mud.com
I had a circuit opening relay fail on me. I keep a spare EFI relay and spare circuit opening relay in the glove box. Symptoms of a bad COR, the truck will try to start but will not stay running after you return the key to RUN. The COR is picked up by a different coil during starting but the holding coil must be functional when you let off the starter or the fuel pump will not keep running.
 

Users who are viewing this thread

Top Bottom