3FE Owners Check-In

Joined
Nov 15, 2018
Messages
95
Location
Signal Mtn
But I have been thinking, the p/o probably didn't wire it correctly, I would look up a diagram and double check that the wires are plugged in correctly, also my cruiser's wires were so old on the outside of the truck that they broke I would just put my hands on the wire and trace it back to the box
Happy Cruisin'
 
Joined
Jan 14, 2017
Messages
348
Location
Wakulla FLA
Hi Folks,
1991 FJ80
181,000 miles on 33x12.5x8 Hankook ATs
Location: Southwestern, AZ
Lots of little (and/or big things) to work on.
Got 8.5 MPG on my first tank. Idle also runs high in Park and Neutral (about 1,200 RPM) compared to other gears.

View attachment 1920232
I have a 1991 80 with 180,775 miles on 33's in the white variety. With an extremely similar brush guard and original roof rack. Weird.
 
Joined
Feb 5, 2019
Messages
18
Location
Southwestern AZ
Not really forbidden as it really is the unmentionable (or magic) screw for the idle on the throttle body. Speaking of forbidden screws I did unscrew those two screws on the air flow meter and learned an expensive lesson.
 
Joined
Nov 27, 2017
Messages
481
Location
Long Island
Replaced the fuel filler pipe. A bit of a PITA but I can now fill up without leaving fuel behind.. no pics, vent line was Swiss cheese and frame bracket bolts broke off and had to be drilled and tapped, pipe got cut to do the install. My next 80 will not be one from the rust belt.
 
Joined
Nov 15, 2018
Messages
95
Location
Signal Mtn
Replaced the fuel filler pipe. A bit of a PITA but I can now fill up without leaving fuel behind.. no pics, vent line was Swiss cheese and frame bracket bolts broke off and had to be drilled and tapped, pipe got cut to do the install. My next 80 will not be one from the rust belt.
yeah it helps to have a southern or south western truck, mine has never left Tennessee and i still have broken a few bolts
 
Joined
Nov 27, 2017
Messages
481
Location
Long Island
Cleaned the IAC, there was a thick coating of carbon. Took care of my rough idle at startup, but not the intermittent cut out or occasional super high rpms at start up, then hard starting condition. Got a code 22 and 42. Coolant temp sensor is on order and a new alternator as back up. New speedo cable will hopefully take care of the code 42. Based on previous threads these issues can take a while to sort out.
 
Joined
Mar 2, 2019
Messages
43
Location
Missoula Montana
Rock auto had stop tech rotors on sale not long ago, I got those and Akebono ceramic pads, remain calipers from Napa, centric replacement brake lines. Can’t comment on braking performance since I still need new rear brakes and I think my drums may be warped.
Did you get the late model 96 calipers and rotors. They are supposed to bolt right up. But you need 16" wheels and bigger dust Shields
 
Top Bottom