Spark Plugs with Oil

Joined
Dec 16, 2018
Messages
6
Location
Birmingham, AL
2008 LC. So I'm just over 100k in miles and took to the shop for routine maintenance. Oil change, differential fluids changed, fuel system cleaning, spark plugs replaced. When they pulled the plugs they told me that the plugs had oil on the threads, especially 1 and 8. He showed me the plugs in a little pan with oil on them. It was on the threads and on the top white ceramic part. I was pretty surprised by this since I've had zero issues or symptoms with the vehicle that would indicate an issue. Then told me it would be an $850 job to replace the valve cover seals and the plug tube seals. We got down to almost half that price. Has anyone else experienced this? Again, it was surprising to me because it's smooth and runs perfect. Maybe just fortunate timing and something they just caught early? Interested to hear opinions and thanks.
 
Last edited:

Hoosier Daddy

SILVER Star
 
Joined
Jul 1, 2005
Messages
1,039
Location
CO Springs
Same thing here, at 130k miles. My theory is that a clogged PCV valve was the root cause in my case, but that's not proven. Please check your PCV though and let us know what you find.
 
Joined
Mar 9, 2019
Messages
5
Location
Pennsylvania
Haven't experienced it on the LC, but I've seen it enough in other makes to know it's common. I've seen oil almost completely submerg the spark plugs and and the car run perfectly. Usually the tube seal rubber hardens due to heat and age and no longer seals properly causing the leak. Glad you got the price down, 850$ seemed excessive!
 
Top Bottom